SmartThings Community

Https://graph.api.smarthings.com Failed to load devices


(Brice; SmartRulesApp.com) #70

Great! It looks like it’s working now for everyone in the US, but still an issue for those in the UK. We’ll continue working with ST to get that part working as well.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #71

Please follow UK SmartTiles Status below…
USA / Canada installations are back operational; but we’re waiting for further information on the Developer’s Call tonight to see if there’s new procedures we should be following and what is the risk of future disruptions.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #72

It’s going away … eventually. Ben’s quote was “end of the year”, but with a “wink”, implying there will be flexibility and/or delays.

@Ben and @slagle have committed to ensure at least the high-profile self-shared OAuth web services app developers will be assisted through the appropriate conversions … pretty much assume that means our SmartApps need to be submitted for review and publication.

Folks with smaller user bases of their shared items will surely tag along and benefit from our combined efforts. If you have a SmartApp you’re concerned about, drop me a Private Message, as I’d like to know more.

It’s a shame that this platform change was made without advance notice so that we could have avoided user impact and saved ourselves some worry and diagnostic time… but the interim resolution was implemented quite quickly, so that is encouraging.


(Ty Bauer) #73

CleverObjects is still not completing the authorization process. If you would like some screenshots I will gladly provide them.


(Joshua Lyon (SharpTools.io Dashboard)) #75

CleverObjects is by @Jordan_Rejaud – Ty reported the issue in the CleverObjects thread and I would probably keep the comments there as at surface level it seems like Ty’s current issue is an app-specific issue (eg. CleverObjects requires a lock to be selected).


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #76

Excuse the cross-posting, but in the interest of proving we’re back (cross-fingers), please see our SmartTiles Version 5.5 Release announcement


#77

5.5.1 is rockin the Casbah!


(Brice; SmartRulesApp.com) #78

A fix is ready for SmartRules users in the UK now too. Unfortunately, our fix cannot roll out quite as quickly as SmartTiles, because we’ll have to wait for Apple approval. Anyone interested in helping us beta test, please send me a private message or email to support (at) obycode.com.


(Rfg81) #79

Hi, I saw this topic and it seems I have this problem. I’m not able to load devices for this smartapp: https://github.com/oehokie/SmartDSC/blob/master/smartapp/dscAlarmIntegrationSmarththingsApp.groovy .

I’m able to select the location when trying to authorize but “my devices” don’t show up. It doesn’t seem to be fixed…

@slagle Could you please help me out?


Documentation Updates - 11/19/15
(Tim Slagle) #80

You’ll need to reach out to the developer that wrote that integration to see if they can get you sorted out.

The developer will need the information from this thread most likely:


(Rfg81) #81

I’m trying to use this URL:

https://graph.api.smartthings.com/oauth/authorize?response_type=code&client_id=CLIENT_ID&scope=app&redirect_uri=http://localhost

Of course I’m replacing CLIENT_ID to the right OAuth Client ID…


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #82

Try this:


(Rfg81) #83

I tryed to use the URl you mention on your post 38:

//STEP 1 - Get Access Code
if(!isset($_REQUEST[‘code’]) && !isset($_REQUEST[‘access_token’]))
{
header( “Location: ${apiurl}/oauth/authorize?response_type=code&client_id=$client&scope=app&redirect_uri=”.$url );
}

I can see my location and select it, but afterwards It doesn’t show any of my devices that I want to authorize. When I click authorize, it gives me an error saying to contact support because probably I didn’t select any device (because I couldn’t).

This was the only app that is giving me this problem. I have added others in the past with no problem. This is really frustrating…

Could you please do a small test on your side and add this SmartApp (https://github.com/oehokie/SmartDSC/blob/master/smartapp/dscAlarmIntegrationSmarththingsApp.groovy) and try to give it access to your devices?

Thanks for any help!


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #84

Sure… I’ll give it a try later today.

If you are debugging, do the best you can to trim out all the extra Preferences Pages that aren’t critical to do an OAuth test. Perhaps copy the entire SmartApp, delete all logic except for basic device selection and mapping definition stub methods.

It is more than likely you are hitting a SmartThings bug (if you haven’t noticed, there are dozens of bugs), that, unfortunately, is impossible to determine how to isolate without tediously trying everything.


(Rfg81) #85

Following your advice, I removed all the code and I created a simple example. It seems the problem is related to using the “pages”. I got an example from the smartthings tutorial. The following code works:

preferences {
section(“When activity on any of these sensors”) {

    input "contactSensors", "capability.contactSensor",
        title: "Open/close sensors", multiple: true
    input "motionSensors", "capability.motionSensor",
        title: "Motion sensors?", multiple: true
}
section("Turn on these lights") {
    input "switches", "capability.switch", multiple: true
}

}

The following code doesn’t work:

preferences {
page(name: “pageOne”, title: “When there’s activity on any of these sensors”, nextPage: “pageTwo”, uninstall: true) {
section(“Choose sensors to trigger the action”) {

        input "contactSensors", "capability.contactSensor",
            title: "Open/close sensors", multiple: true
        input "motionSensors", "capability.motionSensor",
            title: "Motion sensors?", multiple: true
    }
}
page(name: "pageTwo", title: "Turn on these lights", nextPage: "pageThree") {
    section {
        input "switches", "capability.switch", multiple: true
    }
}
page(name: "pageThree", title: "Name app and configure modes", install: true, uninstall: true) {
    section([mobileOnly:true]) {
        label title: "Assign a name", required: false
        mode title: "Set for specific mode(s)", required: false
    }
}

}

So it seems that for some inexplicably reason, I don’t have access to authorize my devices if there is any page available in the App. Is there anyone I can contact here in the forum about this?

Thanks for you help!


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #86

Your discovery sounds correct, actually.

Maybe you can put your main inputs on the primary preferences and reference additional pages using HREF. Sorry I don’t have an example available, but, if I find one I’ll post again here.

Regardless, you should still be able to authorize the SmartApp with 0 Devices (which will “install it” unconfigured) and then the user can use the SmartApp configuration / preference pages inside the mobile App to select Devices and other Preferences. This is how SmartTiles does it.


(Rfg81) #87

I tried with HREF and it doesn’t work either. This is the example I used:

preferences {
page(name: “hrefPage”)
page(name: “deadEnd”)
}

def hrefPage() {
dynamicPage(name: “hrefPage”, title: “href example page”, uninstall: true) {
section(“page”) {
href(name: “href”,
title: “dead end page”,
required: false,
page: “deadEnd”)
}
}
}

def deadEnd() {
dynamicPage(name: “deadEnd”, title: “dead end page”) {
section(“dead end”) {
paragraph “this is a simple paragraph element.”
}
}
}

So I don’t know how to fix it…

@slagle Is this a known issue?


(Jim Anderson) #88

We’re working on docs that will discuss some differences in how SmartApp preferences work as part of the Authorization flow. Will update you soon.


(Rfg81) #89

Thanks for your answer. Would you be kind enough to share an ETA when this is going to be available?


(Jim Anderson) #90

http://docs.smartthings.com/en/latest/smartapp-web-services-developers-guide/smartapp.html

And

http://docs.smartthings.com/en/latest/smartapp-web-services-developers-guide/authorization.html

We will make an announcement today; we still need to doc how the preferences work with the auth page.

We also updated the example app found here: https://github.com/SmartThingsCommunity/Code/tree/master/smartapps/tutorials/web-services-smartapps