Https://graph.api.smarthings.com Failed to load devices

I have been using smartrules for a while now…Used it on an Iphone 5S and just loaded it onto an Iphone 6S - was working fine but now I get the error listed above. It recognizes that I am logged in but it can’t load the devices - this is only on the 6S…well I didn’t want to log out of the 5S because I am afraid it might happen with it as well. Everything else is working fine. I have deleted smart rules, rebooted everything…no change. Any ideas?

Dave

1 Like

@obycode is the developer. Perhaps he can help.

Thanks for tagging me @btk.

That sounds like one of the occasional SmartThings OAuth issues that pop up randomly and soon go away. I know that they have been messing with OAuth recently in hope of getting the UK folks working, so that could be related. Are you in the US or somewhere else? I just logged out and back in on a few test devices and everything seems ok. How long have you been seeing this issue @David_Forsthoffer? Could you try it again and post a screenshot of the error.

FYI: I am experiencing the same problem with SmartTiles.

If someone (who does or doesn’t have SmartTiles), in the USA, would like to try, please use this link:

  • (redacted pending updates from SmartThings, since issue is confirmed.)

Confirmed. I don’t currently have SmartTiles installed, but I get the “Failed to load devices” error when I try to install.

1 Like

Thanks…

@625alex and myself are assuming this is a typical SmartThings “hiccup”…

with the alternate theory that SmartThings is trying out a fix for UK OAuth and that has caused an unplanned outage of unknown scope and duration.

1 Like

I am receiving the same error when trying to access SmartTiles or SmartRules. Maybe it will be better by morning.

We can only hope.

1 Like

Hey guys,

Looking into this.

1 Like

It just started this evening and has been this way for several hours. I tried to upload this file earlier but the website was set to read only? well finally able to upload this…here it is. The problem still exists.

Dave

1 Like

SmartTiles (i.e., @625alex and myself) are coordinating with @slagle to debug.

We’re presuming it is the same platform problem; likely introduced by UK OAuth fixes.

Guys,

We can’t OAuth Smart Apps. It’s broken in the U.S. This is a HUGE problem that needs immediate attention. If you try to OAuth to a Smart App not currently authed…it fails with the same “failed to load devices” error.

Please help.

thanks,

Matt

3 Likes

Ahh, the SmartThings Tango continues. One step forward, two steps back.

1 Like

Welcome to what us UK peeps have had for the last 2+ months.

Just chiming in that I’ve had several user reports of similar issues with being able to authorize devices with SharpTools (and I’m getting destroyed in reviews – thanks SmartThings!).

From the limited posts I’ve seen in this thread, it looks like the authors of the SmartApps are able to continue to authorize, but other users cannot. Is it possible that SmartThings broke the OAuth workflow for self-published SmartApps?

Edit: I just tried with IFTTT (officially published) and it seems to be working fine, but SmartTiles doesn’t work for me and SharpTools doesn’t work if I use a secondary account.

3 Likes

We understand believe us

That is correct…exactly spot on!

To reiterate, @slagle is officially working on resolution, and has code from SmartTiles installer and a few other questions answered by myself and @625alex.

@slagle will be following up with the engineers who pushed yesterdays OAuth UK fix this morning.

I wish we were important enough to warrant an immediate rollback… Our combined installs must rival IFTTT… Well, most certainly US vs UK!

But if they rollback, it may be harder to trace the problem.

I updated SmartTiles website to indicate installer temporarily unavailable.

We have opened a Tech Support ticket, perhaps each of us should… “for the record”.

2 Likes

This “only” affects unofficially published SmartApps to Accounts other than the one that has the SmartApp definition. The same problem occurs in a UK test, BTW.

SmartThings marketplace published web services SmartApps like IFTTT, Amazon Echo, InitialState are unaffected (and actually seem to work in UK now… so that’s obviously the root cause… Blame the British!).

Please correct me if my synopsis is inaccurate.

1 Like

I have opened a Ticket #153061 via email to Support@SmartThings.com.

It would be helpful for everyone affected to do the same (as we have been requested to do many times by SmartThings Community relations…). Thanks.

As of yesterday evening, web based standard OAuth to web services SmartApps fails with “Failed to load devices” (for SmartApps shared to other SmartThings users, but not published in the SmartThings native marketplace).

Our particular SmartApp: SmartTiles (installation link redacted)

Affects ~10 Developers (at least!) and potentially hundreds of Customers.

Details in Community Topic: Https://graph.api.smarthings.com Failed to load devices

Tim @Slagle has collected some details and is researching, but we would appreciate escalation, http://status.smartthings.com update, and tracking.