How to request to add fingerprint to Stock Driver?

I have two GE/Jasco outdoor switches, one has been migrated to the stock ST Edge driver, while the other has not. They were both using the stock “Z-Wave Switch Generic” DTH (non-community created)
I have looked the fingerprint file for “zwave-switch” here: SmartThings Edge Drivers and it is not in there. Is there a proper channel/process to request to have a fingerprint added to the Stock Driver?

Here is the z-wavealliance page for the device:

And here is the information for the fingerprint:

zw:Ls2a type:1001 mfr:0063 prod:4F50 model:3034 ver:5.52 zwv:6.04 lib:03 cc:5E,55,6C,9F,22

They’re drafting the Edge drivers contributing guidelines as we speak. It looks like they will only accept pull requests from companies looking for WWST certification or bug fixes.

You could try logging an issue on their repo and see if they notice


Can you share with me the link to the stock DTH where you saw that fingerprint, please?
I entered the SmartThings Public repo (DTH zwave-switch-generic, branch “Master”) and I don’t see that specific model (3034) included.

Do you have this DTH saved in your IDE account?

1 Like

Hey @nayelyz,
I honestly never looked for the fingerprint in the DTH, I pulled the fingerprint information from the IDE where the device is still listed as a device without “placeholder” in the IDE. I never used a custom DTH for it, and ST used that as the DTH when I added the device.

I just noticed the older version had moved over to an edge driver, while the newer one did not so I tried to find out why. So long story short, I do not have a specific DTH saved with the fingerprint in it.

Maybe it was paired to the DTH by the generic cluster info? (line 24)

Aaah, it could be. Good catch, @Automated_House!
The same generic fingerprint is included in the driver:

Now that your device was migrated, the Edge driver is installed and all compatible devices should connect to it.
I think it wasn’t included in the migration because the fingerprint that allowed its connection is not specific.

Have you tried reinstalling the device?

1 Like

The production version of that driver has all of the generic fingerprints commented out. So I have my doubts whether re-installing the device will pickup the Edge driver.

1 Like

AFAIK, the driver installed for migration, is the one in the “beta” branch (those are the same in the official channel invitation), not “production”, that’s for the default join.
As a reference, here’s the list of migrated DTHs:


ah, ok, that makes sense.

I will give it a shot re-installing tonight when I get a moment. Can’t hurt.

1 Like

I removed and readded the device twice. The last cycle, I rebooted the hub in between the removal and the add. It still joins with the Stock DTH.

Ok, let me check some details with the engineering team. I’ll keep you updated.

1 Like

@Controlbreak, can you help us get the following info, please?

  1. Check which drivers are installed in your hub and share a screen capture.
    To do so, follow these steps:
    a. In the ST app, go to the Hub and enter its details
    b. Click on the menu (three-dot symbol in the upper-right corner)
    c. Select “driver”.
    You’ll see the list of installed drivers and the channels in which your Hub is enrolled.

  2. Check what is controlling each device, you mentioned you have two GE/Jasco outdoor switches.
    By “one has been migrated to the stock ST Edge driver”, do you mean it was automatic or you installed the driver directly?
    In the IDE, drivers are not fully supported and also, there are reports of certain issues with it, so, to have a better reference, we need your help by installing the CLI.
    After this, follow these steps:

    1. List the devices with the command:
smartthings devices
  1. Copy the Device ID of the first device you’ll check. Run the same command but add the ID (and he flag -j) at the end:
smartthings devices device-ID -j
  1. Check if in the details there’s a property called “zwave” that contains the driver ID. This means it’s using a driver.
    You can also use the command below to see the driver’s name:
smartthings edge:drivers driver-id

Otherwise, there should be “deviceTypeName” where it should include the DTH name.
This is a way to identify what’s controlling the device (DTH or Driver) and the details that help us recognize it.

Here is 1.

For the older device using a Driver these are the outputs:
smartthings devices 0fe6b4a0-738b-447d-88ab-d95d95b1e2f5 -j

Driver id: 2cbf55e3-dbc2-48a2-8be5-4c3ce756b692

smartthings edge:drivers 2cbf55e3-dbc2-48a2-8be5-4c3ce756b692

And for the Newer one this is the section with the DeviceTypeName:

I hope I got all that right… :sweat_smile:

ok, I just want to confirm, did you install the Z-Wave Switch driver directly or you noticed the device started to use the driver automatically?

Here, in the channels registered, are there only two, or you can scroll down?
To confirm, please execute this command:

smartthings edge:channels:enrollments

It was using the driver automatically.

There are only the two subscriptions:

I have only stumbled back into the rabbit hole once the other issue you are helping me with popped up. I am sure there will be more later.

Ok, thanks for the info.

The older device that uses this driver, is a different model from this manufacturer, right? The fingerprints included are for models 3030, 3031, or 3032 and the one that connects to the DTH is 3034
This means they don’t have the same fingerprint. This is just to understand why one device uses a driver and the other doesn’t.

Yes, totally agree. That is why I am interested in adding a fingerprint to the driver.

Thank you again for all the support.

Im trying to get the electric meter one to work but i think it needs the fingerprint adding.
Any ideas on this

See below