How to keep ST running in background? - Oneplus 6


(Denny) #1

I use SmarttThings at home for automation. Part of that is using the app as a presence sensor for changing modes from Home to Away and vice-versa.

Since I got my OP6, I’ve not been able to keep ST running in the background. Any push notifications that come from SmartThings do not come up unless I very recently launched the app.

I have a perimiter set about ~3 minutes away by car, and even so, I can sit in my driveway waiting for the system to disarm, before manually opening ST and then it updates my location and things happen immediately.

I disabled battery optimization for both apps but still got the problem.

My girlfriend is using the app on the iphone x (IOS) but didn’t have the problem.

Please help


#2

Looks like you’re not the only Oneplus 6 person having this issue:

https://forums.oneplus.com/threads/how-to-keep-a-particular-app-alive-in-background.491706/

What about turning off Advanced Optimization? https://forum.xda-developers.com/showpost.php?p=77207357&postcount=12


(Denny) #3

When i disable these features i do it for every app on my phone and my battery starts to drain.
I only wan’t the smartthings app not every app.

Thanks for the reply


(Denny) #4

Is there a better way for the presence ? For example when i connect or disconnet to my wifi? I have implemented the ifttt solution but that is working to slow…


(Denny) #5

I found a workaround.
I added my smartphone as a presence sensor in the new Smartthings app https://play.google.com/store/apps/details?id=com.samsung.android.oneconnect&hl=nl
https://support.smartthings.com/hc/en-us/articles/200292279-How-do-I-use-my-phone-as-a-presence-sensor-

After that i configured my security on the smartthings classic app :smile:

Seems to work for now i keep you updated.


(Denny) #6

Still works like a charm guys. Try it out!


#7

How did you use the NEW app for presence yet the old classic app for security? I disable/enable security based on presence. How can I get that to work in how you are explaining?


(Denny) #8

Let me explain:

  1. install the new smartthings app https://play.google.com/store/apps/details?id=com.samsung.android.oneconnect
  2. install the smartthings classic app https://play.google.com/store/apps/details?id=com.smartthings.android
  3. open the new smartthings app
  4. Tap on the Dashboard tab
  5. Tap the three dots in the top right
  6. Tap Settings
  7. Toggle ON the switch for Use location information
  8. If prompted, give SmartThings access to use your phone’s location services
  9. Tap the back button to exit
  10. open the smartthings classic app
  11. my home
  12. Under things you see now your phone’s name as a presence device
  13. open automation and create a new routine
  14. for example alarm active
  15. set turn off these lights if you got some
  16. set smart home monitor to: Armed (Away)
  17. change the mode to: Away
  18. Automatically perform “alarm active” when everyone leaves
    Wich? Select you’re phone presence

After this make sure you lock both apps in you’re multitask screen
1485079230022

When you use oneplus make sure you disable battery optimalisation for both apps

  1. Go to Settings
  2. Battery > Battery optimisation
  3. Find the app you want to keep awake all the time
  4. Tap on it and select “Don’t optimize” option
  5. Tap “Done” to save