Android Presence Sensing not updating quickly

presencesensor
presence

#1

I’ve been suffering a lot of false alarms and routine failures that have been tracked down to the Android app not updating location until the phone alerts for another reason… typically that the alarm has gone off. My location is pretty large - about four city blocks radius - and I’m typically inside it for at least five minutes before getting to the door.

How can I improve the responsiveness of the presence detector? I’m running the latest version on Android; HTC M8 with Marshmallow.


Recent presence glitches?
Presence detection
Problems with Mobile and Life360 Presence sensors
(Ben W) #2

Check to make sure wifi is turned on as well as GPS tracking. Its under Settings-> Location Mode set to High. Don’t turn off wifi, this is how Android quickly knows about where you are (nearby access points)

Don’t kill the ST app in Android. My wife does that and it kills the process in the background so it does not update her very quickly or at all until she opens it back up.

Sadly you may need to increase range. I have my range fairly far out and I still get a false alarm every few weeks.


(Convinced ST will never be unbroken…) #3

This sounds like a Doze issue. Try turning off battery optimization for the SmartThings mobile app.


#4

Thanks. I’ve set ST to not optimize battery
; here’s hoping.


(Ben W) #5

Don’t think its Doze issue. Doze takes hours to dive into deep sleep.


#6

Setting the ST app to not battery optimized did not help. So here’s where I’m at:

  • HTC M8 running Marshmallow
  • GPS is on
  • SmartThings is allowed Location Services
  • SmartThings is set to not be battery optimized
  • The range is pretty large, like multiple blocks around my place
  • Today I spent at least 15 minutes inside that range (at an office store and a pet store) before going into the building and the front door
  • And I still got an alarm

From experience I believe that once the app is brought into the active foreground it registers, but that seems like it should be an unnecessary step. What else can I do to improve responsiveness?


(Convinced ST will never be unbroken…) #7

Is your phone plugged in during your tests? If not, try connecting it to a charger.

Also, under settings-location, what mode is set?


#8

I kind-of doubt having to keep the phone plugged in would allow it to be a useful presence detector.


(Convinced ST will never be unbroken…) #9

Just for testing purposes only; to rule out any battery saving algorithm.


#10

Did you go into your account settings in the app and modify the geofence? Click on the map and make the geofence as small as possible, that should help some.

I would also say to make sure you have High Accuracy mode enabled. Do you have location reporting and history enabled?


#11

How does a small geofence help? It’s not detecting me entering the large one?

Not sure about the reporting/history; where are those settings?


#12

Oh sorry didn’t see that part.

Reporting/history are under location settings, either at the bottom or under the 3 dot menu depending on the version of android you are on.


(Greg) #13

The only way I can get 100% accurate android presence with ST is by leaving Android Location mode on “battery saving”


(Ben W) #14

I would also expand the geofence, depending on your area maybe there is not enough access points to trigger an update.

Is Wifi on?


#15

GeoFence is quite large and in a very populated hi-tech area. WiFi is on.


(Ben W) #16

I would make it larger at least for a test. Maybe the fence is not stored right and resizing it a few times would correct coordinates size.

Mine is about 0.5-1 miles out in the burbs, and often it triggers when I am walking up to the door (at least 5 min in the fence)

My only other thought is that when its in the background it was killed, and bringing it to the foreground fixes it. Is there any battery management apps running, or do you have you battery mode set to “Power Save” or “Effieciency” (which may be killing background processes).


(Jay M) #17

I just biked home through the largest geofence. Sat outside my door turned on smartthings app and walked in. Been home for 15 mins still not present. When I open the geofence you see my position dead center and still not present. All of my GPS places me at home. It’s smart things this time.


#18

It’s getting worse… now the system is not updating the presence for 20 minutes even when I’ve left and am using the phone. Presence is so unreliable that everything seems to cause alerts.


(Ben W) #19

Check the application settings to make sure ST is still running in the background. The only thing I can think of is some power management app, or HTC tweaks that killing background processes so they are not updating.

Did you check your battery mode and make sure it is not on the settings I mentioned before? Another test is to turn it on “performance” and see if you get better updating.

My 2 phones are running close to pure Android (CynogenMod on onePlus, and a Nexus 5x) and we get decent updating. Not perfect but would guess 90%+.

Edit:
This is what I think is happening on most the android issues, is memory management/power management is killing background apps. If that happens ST will never update.


#20

I’ve been having the same problem.