How to connect IKEA 5 buttons Remote with IKEA Bulb and Hub at the same time?

Hi all,

Any one know how to connect IKEA 5 buttons Remote control with IKEA Bulb and Hub at the same time (bulb using edge driver)?

I tried to pair remote with hub and then pair remote with bulb but as soon i pair remote with bulb, remote doesn’t connect again with hub


Quite a few people have done this with both IKEA and other Zigbee 3.0 brands.

The basic steps are:

One) pair the remote and the bulbs to the hub. This is necessary to get everybody on the same Zigbee network. I don’t think it’s going to matter whether you are using an edge driver or a groovy DTH. But they have to all be on the same network.

Two) once everything is paired to the smartthings network, you can then use touchlink commissioning or another direct method to assign the bulbs to the remote.

As for your specific situation…

When you say “the remote doesn’t work“ does it still show as a device in your smartthings app? Does it work to turn the IKEA bulbs on and off? Are you saying that you can’t have the remote controlling the IKEA bulbs and do other things with it in smartthings at the same time? Or?


1 Like


Thanks for quick reply.
Let me clarify:

  1. I pair bulb to Hub
  2. I pair remote to Hub
    Now both bulb & remote in same smartthings network through same hub
    I can control bulb through smartthings app
    I can control other devices connected to same smartthings network/Hub by prorgramming remote buttons press/hold in remote in smartthings app

To have direct control from remote to bulb i pair the remote to bulb by pressing and hold back button of remote near battery close to bulb
now I can control directly the bulb through remote but I lose the ability to control other device in same smartthings network from remote (press/hold)

yes shows as a device in smartthings app

yes on/off and brightness but right &left buttons doesnt do anything

other way around
i can control bulb but not other things in smartthings network

can you please explain what do you mean?

actually i have 2 ikea 5 buttons but with 2 different HW builds (Old/new)
The old one i can do direct bulb control + control other devices in same smatthings network
The new one, only can control bulb once paired again to bulb but not anymore other devices through press/hold programming

1 Like

use group enabled edge driver .


thanks, can you direct me please to correct driver?

Do both buttons have the same firmware?

This may be an Tradfri firmware issue.

I recall reading in one of the numerous (too many?) Home Automation groups I belong to that a somewhat recent firmware version/update for some (all?) of the Tradfri buttons either purposely removed or broke the functionality you’re trying to use.

I dont think they have same firmware as one is old and another one is new and i dont have IKEA Hub to update firmware
This is what I though about it too I believe!

I just added a 5 button remote to my SmartThings hub.
It’s using the Zigbee Button Edge driver.

Firmware version is 23080631 (V2.3.080) which is from October 27, 2021

I’ll see if I can connect this to one of my Tradfri bulbs that is not tied to any automations in case the Remote steals the bulb from SmartThings.

EDIT: No luck getting the remote to link to the Tradfri bulb.
I am able to get it working for automations

1 Like

Try again
You need to keep pressing and hold the pairing button back side of Remote close to bulb for than 20 seconds and you will start seeing the bulb dimming keep pressing tell bulb stops dimming and then you can control bulb directly through remote

Nope, the remote with the latest firmware won’t connect to the Tradfri bulb at all.

I have some other remotes that are still new in the box, so I added one with firmware 23014631 (V2.3.014).

I was able to bind the remote to a Tradfri bulb, but by doing that the remote stole the Tradfri bulb from my SmartThings hub.
Now the Tradfri bulb won’t pair back up with the hub again for some reason.

This is weird!

It seems many different remotes with different behaviors
In my case i have 2 of them and both i can connect them to the Tradfri bulbs after first i paired them to hub and even after i connect them to bulbs, the bulbs keep connected to hub and can still be controlled through smartthings app

My only issue that one of them after i pair it to hub and then pair it to bulb, it loses the control through hub but still i can see it in smartthings app

I am not able to find each firmware version, how do find it?

Press the three dots and select Information

It should be listed there.

Are you resetting the remotes or simply holding the remote next to the bulb and pressing the reset button once and holding it?

No resetting, just holding the remote next to bulb and keep pressing and hold the reset button till bulb starts dimming and finish

OK. I’ll try again once I am able to get my light back.
It refuses to pair with my SmartThings hub or my Echo 4 with Zigbee hub built in.

I’ll hook my Hubitat hub back up and see if it will connect to that one.
Trying every hub I own except the Ikea one if I can help it :smiley:

1 Like

What an odd bulb.

SmartThings, Echo 4, and Hubitat wouldn’t pair with it.
I dug out the Ikea hub and the bulb did pair with it, updated the firmware, but now the bulb won’t reset so I can try and pair it back to SmartThings.

Edit: FINALLY got it paired with SmartThings. They apparently changed the reset procedure with the updated firmware. Short “on” periods with longer “off” periods did it.

Glad I got it back, as these are the only affordable E12 Zigbee bulbs around (not paying the “Hue tax”).

Test #1 - 5-button remote with the latest firmware and a Tradfri E12 bulb.

I took the 5-button remote with the latest firmware and connected it to my bulb by pressing and holding the reset button.
The bulb did it’s dimming routine, the bulb and the remote stayed connected to SmartThings.

The remote doesn’t do anything that is not associated with a routine.
To confirm, I removed the logic for the “power” button on the (Button5 in the Edge driver).
When I press the power button, the light it is supposed to be connected to via Touchlink does not react, but the Button5 entry in the Edge driver does acknowledge the button was pressed.

Test #2 - 5-button remote with older firmware and a Tradfri E12 bulb.

Connected the remote to the bulb like I did in Test #1.
The bulb did it’s dimming routine, the bulb stayed connected to SmartThings, but the remote did not stay connected to SmartThings.

The remote worked with the bulb fine but was not registering any button presses when watching the screen in the app.

I had to reset the remote to get it connected back to SmartThings and detach it from the bulb.

1 Like

Try to connect remote first to hub then connect it to bulb. follow this order
Reset remote first before you start above

Ugh you spent a lot of time trying :slight_smile: most likely both of you get different versions of driver as ST is updating to new Edge drivers