Ikea Tradfri Remote Control

Hello all,

Just curious if anyone has any experience with this :
https://www.ikea.com/us/en/p/tradfri-remote-control-00443130/

??

Thanks

Yes, they are working.

There are multiple topic about these remotes. Like this…

1 Like

They are…kinda. There is currently a bug with the new app where the button setup on the device screen doesn’t show up. But you can still use other smart apps like Smart Lighting.

1 Like

Or the ABC, Advanced Button Controller. (Who uses the new app anyway… :wink: )

:raising_hand_man: (most of the time :stuck_out_tongue:)

1 Like

Thank you. I wasn’t sure if this was a new version… I had just started looking at the Ikea offerings and the remote was listed as new, so I thought it was a ‘new’ version.

Is it stating there a number like E1810? That is what I have.

@BroderickCarlin, you might going to have a brainfart… IKEA did the same with the remotes as the motion sensors. There is an old version called E1524 and a new version called E1810. That’s why is listed a lot of places as “new”.

The old version has a big button in the back under the cover, the new one has a small button only. From the front they look the same. The number printed on them is different too.

Old remote E1524:

Which one have you wrote the DTH for?

Do you know if the “new” button joins as a Tradfri remote? and if so, if there are any issues being encountered? I’m guessing we’ll need to apply the same fix that the motion needed :stuck_out_tongue:

1 Like

I have the new one, and it works. But some people are having issues, as it reports only battery. I guess it might be the same reason. I cannot confirm it fully. We need to do a survey first.

1 Like

@Joedarkon, could you please post here your issue with the 5 button remote together with the hardware version number of your remote? (Please see my comments above, and you will understand it.)

@kjartan, could you post here your issue together with the answers to my points from the other topic?

@ozcet, have you managed to fix your issue with the 5 button IKEA remote? If not, could you post here your hardware version number?

@markplewis, have you managed to pair your 5 button remote correctly? If not, could you post here as above asked. Thanks!

1 Like

@prjct92eh2, which version remote do you have?

@numbers1thru9, what version 5 button IKEA remotes do you have? Are both of them working fine? Which one had issues with the pairing?

Hi, I have old one 1524 remote. And its still showing just the battery…my ST hub version is 2.
Thnx

I also have a 2button remote from tradfri. Its not working too…

Have you ever installed any custom DTH for these devices to the IDE? If yes, then have you deleted them before pairing?

lots of interaction, nice!
version I have is E1810 with 5 buttons.
it natively connects as the remote. I did try a custom DTH but removed it at some point.
it is reporting battery status in the beginning, but that even seems to have stopped now.

Hope it helps!

From the logs: 9:49:53 PM: debug Creating event: [value:87, name:battery, descriptionText:IKEA TRÅDFRI Remote battery was 87%]
9:49:53 PM: debug Parsing message from device: ‘read attr - raw: 4A070100010821002057, dni: 4A07, endpoint: 01, cluster: 0001, size: 08, attrId: 0021, encoding: 20, value: 57’

And here the details when pairing using the classic app:
9:34:20 PM: debug Creating event: [value:21, name:battery, descriptionText:IKEA TRÅDFRI Remote battery was 21%]

9:34:20 PM: debug Parsing message from device: ‘read attr - raw: 596B0100010A2100002015, dni: 596B, endpoint: 01, cluster: 0001, size: 0A, attrId: 0021, result: success, encoding: 20, value: 15’

9:34:19 PM: debug Parsing message from device: ‘catchall: 0104 0001 01 01 0140 00 596B 00 00 0000 07 01 00’

9:34:19 PM: debug Parsing message from device: ‘catchall: 0104 0001 01 01 0140 00 596B 00 00 0000 07 01 00’

9:34:16 PM: debug Configuring device TRADFRI remote control

9:34:15 PM: debug Creating child 5

9:34:15 PM: debug Creating child 4

9:34:15 PM: debug Creating child 3

9:34:15 PM: debug Creating child 2

9:34:15 PM: debug Creating child 1

9:34:15 PM: debug Creating 5 children

Yes, still there because I using wall plug…
IKEA-Tradfri
Author:
Edvald Eysteinsson

I deleted all custom DTH’s . Changed Ikea bulbs as ZLL Dimmer Bulb and Ikea wall plug as ZLL switch.
After that should I try again to pair 5 button old (V. 1524) remote ? Any Hope ?

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.