How to change my account name

Had SmartThings.a few days now.
Using Android app, when I go into ‘My Account’, at the top it shows


How do I change the 2 N/A’s to my name as its not a clickable field?

You can edit this in the IDE that’s accessible on the web.

See post linked below to help you figure out which exact address to type into your web browser.

Thanks Mark.

I’m so new to this that I didn’t even know about IDE.
I logged in OK. Then went to My Locations, Home, clicked my Account Name, then Edit the full name field and Update. That should be it right? - No. It still shows N/A N/A on my phone.
Is there something else I need to do?


Try logging out and back in on your phone?


Just tried it, but still the same. This is wierd !

I’m out of ideas.

Open a support ticket, they can probably help.

1 Like

OK. Thanks for trying.

Hi. Did anyone end up solving this? I have the same issue.


contact ST support at

I think I found a workaround. In. the IDE got looks like the name is changed but it doesn’t stick. Instead go to and sign in. the there, then go to your profile and change the name.


Does sadly does not work in my case Samsung account name succeeded, but in smartthings IDE and in the phone app it’s still the old name.

If you open your Location in the IDE the account name, which by default is something like ‘’s account’, is a link. That takes you to a page where you can edit the account name and your full name.

Seems to work on the IDE but I don’t know if it syncs across to the app. Probably not as the IDE predates Samsung Accounts. More likely to be a relic.

Oh hang on, it says that earlier in the thread.