SmartThings IDE

I have had this problem before, but it somehow resolved itself. This time, not so much.

When I login to the ide, (It sends me the verification code along the way), I get logged in and get the ide screen, It will show my email address in the top right as logged in.

Click on devices or hubs and it will return “You don’t have any devices yet” which is far from true!

Any suggestions? I’ve even tried incognito in Chrome.

1 Like

go to My Locations first and tap on the name of your location… then you will be fine


Ever since … some recent change… I’ve had to first go to Locations and select my one location after logging into the IDE.

Without that it shows me to have no hubs and no devices.

Thank You!

I had that for the longest time. It went away a few months ago and I no longer have to pick a location first. No idea why.

1 Like

What’s up with this?

except you can’t use posted in the thread above.

Chrome took it out with a slash through the https, stating that the url is not actually secure.

I used 04 as that’s what I’m on.

However… this works!

needs “useast2”

yep… what I get for replying when I am out and about… I got it wrong. I corrected it above

but note… not everyone is on the one you posted. users can have different SHARDs they are on.

:slight_smile: I was having too much fun at Lowes


No troubles at all. Most times I just need a nudge in the right direction!

Thanks Again!!!

Do they sometimes change that url? Reason I ask… I had been using a bookmarked link that always worked before…

1 Like

yes, they changed it this summer. It use to be account. smartthings. com but they now have that pointing to the my. smartthings. com

1 Like

Where is it coming from? It should be either or, at a push,

it was coming from me and mistyping. I corrected my mistake

1 Like