How to add an old contact sensor and/or edit device type? (Schlage RS100HC)

I’m having a problem where one of my two contact sensors is showing up with attributes (wet, smoke, etc) that it doesn’t have and whenever the door opens I’m getting a smoke notification.

I needed to red-do my setup due to my screwup of deleting my location and among my devices I have a pair of Schlage contact sensors. I go to add without a QR code and it is never discovered, so when I click on “don’t find your device?” the only option is Door lock. But it isn’t a door lock, so instead I’ve been able to add it as a Ecolink contact sensor.

Looking at the Samsung account page the one that works has a Device Name and Device Profile of contact-battery-tamperalert, the one that thinks it has a smoke sensor says generic-sensor for both of those. So far as I can tell I’m doing the exact same thing when I add both, and I have tried removing and adding back the one that thinks it has a smoke sensor twice, same thing happens.

There was an old thread at How to actually USE the Schlage RS100hc? - #2 by trotsky40 that claimed you could use to edit the device type but that web page doesn’t exist anymore and on the page advanced/devices the device type doesn’t appear to be editable.

So how can I get this sensor to add just like the other one that is a contact sensor, or change the device type from generic to contact sensor?

The first thing is to find out what “fingerprint” the device is reporting with. That’s the combination of the manufacturer code and the model number.

(this whole concept is unique to the smartthings architecture, so you’re not going to find anything about it outside of smartthings-specific resources, and the manufacturer themselves will probably not be able to help you.)

Usually when a Device is showing capabilities that you know it doesn’t really have. It’s because smartthings didn’t know what to do with the fingerprint it was reporting.

So start by going to the advanced user page in the web UI to your smartthings account and looking at the device details to see what the fingerprint is. You can also compare it with the one you have that is working the way you want.

Also, on the one that is working, note what driver it is using.

then come back and let us know those answers and we can figure out the next step. :thinking:

1 Like

As far as changing which edge Driver it’s using, in the old architecture you could just force a change to anything you wanted. But in the new architecture, the new edge driver must have a matching fingerprint to your device or you won’t be allowed to change. And you have to have the new driver on your hub. So you will have to figure out what edge driver you want to be using and download it. Unless it doesn’t already have the fingerprint you want, in which case you have to ask the edge driver author to add your fingerprint before you download it.

so the steps are:

  1. find out what the fingerprint is for the device
  2. decide what edge driver you want to be using
  3. make sure that edge Driver already includes your fingerprint. If it doesn’t, you have to ask the author to add it.
  4. follow the link the author will give you, subscribe to the channel, and download the desired edge driver to your hub.

Once you have the new edge Driver on your hub, here are the instructions for changing to it. Fortunately, that part is easy. :sunglasses:

FAQ: How to change to a different edge driver

1 Like

For the one that doesn’t work it has
Model: 0001-0002
Manufacturer Code: 011F-0001-0002

The one that works has
Model: 0001-0002
Manufacturer Code: 014A-0001-0002

Both use the driver Z-Wave Sensor

Since the Manufacturer code is different I wonder if somehow I selected different vendors; I thought I used Ecolink both times. If so would there be a way to figure out what vendor the one that works was?

Most likely it was just a firmware difference. We’ve seen this on a lot of devices since the architecture change.

SmartThings has made the decision not to update the official stock edge drivers for devices, which are no longer current with their manufacturers. So the next step is to see if there is a community developer who has created a custom edge Driver that already has this sensor, or that could be made to work with it if the fingerprint was added.

Hopefully someone will respond.

Why did you select ecolink if this is a Schlage sensor? I’m confused. :thinking:

Anyway, see if it’s on this list:

[ST EDGE] Z-Wave Sensor Driver Channel - including specific Ecolink, FortrezZ, HomeSeer, Monoprice and Zooz models

Schlage didn’t have an option for a contact sensor. I don’t have the box it came in, and anyway the device is a few years old so it probably didn’t have a QR code on the box (there isn’t one on the device). So when I started adding it as a Schlage device and selected “add without a QR code” it wasn’t found; the only option after I selected “can’t find your device?” was a Door Lock. Contact sensor wasn’t a choice.

I then figured, well, if I add it as a different brand’s contact sensor maybe it will work and it did for one of them.

But just for grins I removed the device and then tried to add it as a Schlage Door Lock. Lo and behold it found and added it, but still it thinks it has smoke and other sensors that it does not have. And the Manufacturing Code is still 011F-0001-0002

Maybe the one not working right is sending outdated or incorrectly programmed data and I should replace it with a new sensor since it’s not on the list you sent in the 2nd reply. I had thought that selecting the manufacturer when adding the device would set the code but perhaps it is sent in a field by the device since I get the 011F regardless of what I choose as the manufacturer when adding the device.

Correct: the device has the identification information stored in its firmware, and will send that when queried, including at the time of joining to a new network.