How do you control a Nexia thermostat with a SmartThings hub

smartapp_hvac
dth_hvac

(Opie2446) #1

Was considering trying to remove Trane XL 824 thermostat from Nexia hub and seeing if it will work with smart things. Any one have any experience with this


(Edward Pope) #2

Do a search on Nexia Thermostat, there are many articles that might be of assistance to you.


#3

No, I do not think it will work with any other hub.

My research indicates that the XL824 is a hub itself, and there is no software on it to allow it to become a controlled device by another hub.

As you probably already know, you do not need a Nexia $10/month subscription if all you have in your Nexia account is your thermostats.


(Trent Foley) #4

I’ve submitted a Nexia Thermostat device handler and SmartApp for publication consideration. Feel free to test it out.

You will need to first add the device handler:

And then the SmartApp:

After configuring the SmartApp, it will discover your thermostats in your Nexia account and automatically create a SmartThings device for each.


Newbie Stumped after 12 hours research switches and relays: set up one to Control another?
(Vinodmudedla) #5

Thank you for the code Trentfoley. I was able to add my Nexia Thermostat to ST but my 2nd floor thermostat is not created in ST devices.


(Ramsey) #6

First, thanks for your work. This is a much needed device/app.

But I’m not having a lot of luck. In the ‘Right Now’ tab, my temperature tile is white and shows a question mark. But under ‘Recently’, activity is accurately reported. And from the ‘Things’ tab, the temperature is accurately reported.

Also, from https://graph.api.smartthings.com/device/list, current states are accurately reported.

Any thoughts/suggestions would be appreciated.


(Ramsey) #7

Also, forgot to mention, the thermostat and fan mode controls are working properly. I’m just not seeing the colors/value that it looks like you have coded for the main temperature tile along with the multi-attributes.


(Ramsey) #8

After looking into things over the weekend, it appears that the multiAttributeTile is not yet supported in Android (only IOS).
http://docs.smartthings.com/en/latest/device-type-developers-guide/tiles-metadata.html#multiattributetile


(Ajay Prakash) #9

Thank you so much for you work. I was able to add my XL824 to ST. Is there a way to set the heat and cool set points separately if running in auto mode. When i try to change it just changes the cool set point.


(Trent Foley) #10

In an attempt to make use of the multiAttributeTile, I coded the up/down controls to change the setpoint of the last operating mode reported back from the thermostat. It would be easy enough to add addition tiles that hooked up directly to the setHeatingSetpoint and the setCoolingSetpoint methods, rather than the setTemperature method.


(Graham S) #11

Great addition to the ST capabilities. Thanks so much for the work. I seem to have a problem initially adding the device though.
"Caught exception determining thermostats path"
I’ve a single XL824 registered with Nexia and that works fine through their channels. I suspect I may be missing a step in authenticating, but for sure the account details are correct. Any thoughts?


(Jonathan Watson) #12

I am getting this same message:
“Caught exception determining thermostats path”


(Ammar Bhutta) #14

Added device handler, added smart app, gave my nexia credentials- pressed done but nothing appears under things- Should we grant access on nexia account maybe or some other steps that I maybe missing out


(Ammar Bhutta) #15

Looked under notification i am getting exactly the same error "Caught exception requesting thermostats: " also i see error stating “Caught exception requesting auth token” along with “Caught exception determining thermostats path” did any one figure out a solution?


(Jon Press) #16

In the smart app code, look for line “authenticityToken”. Change it to match this:

def authenticityToken = loginResp.data[0].children[1].children[1].children[0].children[0].children[0].children[0].children[2].children[0].children[1].attributes()[“value”]

It seems HTML on the nexia page changed, so broke the previous logic.


(Bhala Ghatate) #17

Thanks this worked and my AC Thermostat is showing up. But my Thermostat has 2 zones and even thought the AC device shows up in the APP I can’t control the two zones.
I get this error in the logs: [name:error, descriptionText:Caught exception requesting thermostats: groovy.lang.MissingPropertyException: No such property: id for class: groovy.util.slurpersupport.Node, displayed:true]


(Ammar Bhutta) #18

Thankyou- worked like a charm, just made the edit last night and all items show up. Great work!


(Jordan Godwin) #20

I actually successfully adding the Nexia Thermostat app and logged in, but afterwards it isn’t ‘automatically create a SmartThings device for each’ as stated above.

Is there something else needed in order to kick that part off?

Thanks in advance and for author’s work on this!


(Jordan Godwin) #21

Disregard my post above. I got it working in the app, minus the ability to control multiple zones. Has anyone else had success with using multiple zones in this smart app (i.e. Only 1 thermostat, but with 2+ zones controlled by the single thermostat)

EDIT:

Looks like the zonesPath doesnt exist anymore, and therefore the zones would have to be created from the thermostatsPath JSON object. I’m going to play with it this weekend and see if I can get the zones working.


(Jack R) #22

Are there home and away controls? I don’t see them