Question About the 'built-in' Simulated Thermostat

I have a Nexia smart thermostat that I am not able to connect directly with SmartThings (I know about the @trentfoley SmartApp here, but it doesn’t work with my specific model).

However, I can use this Nexia thermostat with Alexa (via Nexia Z-Wave Bridge connected to my network via Ethernet).

Since I know that some SmartThings-Alexa integration is possible, and since I already have a fair amount of webCoRE pistons doing things in that area…

I’ve been working on setting up a system of simulated Alexa switches (thanks to @bjpierron here) and a piston in webCoRE that I can use to sync the state of the Simulated thermostat in SmartThings over to the real one in Nexia-land via Alexa.

Well, the problem is that, even though the sync works from the simulated switches over to Alexa (and then on to the Nexia thermostat), for some reason, nothing I do in the simulated tstat gets to the simulated switches.

e.g. piston in webCoRE
If simulated tstat’s setpoint changes to 71, turn ON simulated switch 71.

When I change the simulated thermostat’s setpoint to 71, the related simulated switch does not get turned ON.

So, I guess my question is, are we supposed to be able to use the simulated thermostat to do things like this? If so, I will go ask more about this on the webCoRE forum, but I wanted to know first if this sort of thing is even supposed to be possible.

Sorry I didn’t put this in an appropriate category. Thanks @JDRoberts :slight_smile:

1 Like

Care to share your piston?
There may be another setting that’s preventing this from happening. Maybe a mode restriction got added or something similar.

1 Like

Sorry it’s been so long.
I just hadn’t been working on much of this stuff for a while.

Here is a cropped portion of the green screenshot…

As you can see, I tried it with different data points (cooling setpoint, tstat setpoint, heating setpoint), but none of them work. i.e. when I change the setpoint in the simulated tstat, that change does not get reflected in the on/off state of the set of simulated switches.

Also, it’s really pretty simple; nothing else in there but the code to make this happen. It goes on further below, but only with more temp points like what you see here, and ends with ‘end execute’.

The only restriction is that a particular switch must be ON, which it is.

It seems to me like this simulated tstat is only for looks, and doesn’t have the ability to actually interact with a live system like simulated switches do.

Am I right?

Crazy thing…
I took another look at the code, and decided to play around, and I think I have discovered a work-around.

My whole point here is to track the setpoint so that i can mirror the setpoint of the tstat in a set of switches. So, I was using ‘Changes to’.

Just now, I tried it with ‘Is equal to’ instead, and it looks like, even though I have been told to use ‘Changes to’ instead or have found that to not work in other places, it actually works in this case.

So, I guess I will just go modify the code to use ‘Is equal to’, and be happy. :slight_smile: