SmartThings Community

How do I install the SmartThings app on a Generation 7 Fire HD 8


(Joel W) #1

I just received my Fire HD 8 and I am not sure if I can install SmartThings app as this is not rooted. Is it possible?


(Mark) #2

Possibly.

There are threads about this.

It might depend on whether you still have a SmartThings account.

And you probably have to sideload the google play store first.


(Joel W) #3

Is there any instructions on doing this here? or do i have to search on line?


(Mark) #4

I’m not sure, try searching the forum first.

Or this forum has a lot of good instruction threads for doing various stuff to fire tablets.

https://forum.xda-developers.com


(Jimmy) #5

There are plenty of instructions out there for installing the google play store. Then You just install SmartThings Classic. The tricky, if not impossible, part is logging into the app if you have a Samsung login. The site the Samsung login uses does not like Silk and everything I’ve tried to set a default browser to chrome doesn’t work.


(Joel W) #6

Is Silk a Safari derivative? I thought Chrome is google choice.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #7

It’s not possible. As far as I know!

I’m watching this thread to find out if I am wrong… Or is there a very complicated method…?


(Joel W) #8

I looked all over, it was doable until this last update, so I think it will not happen for a while if ever.


(Jimmy) #9

Sorry, meant Silk. Doesn’t like silk.


(Scott Sharp) #10

You can install the SmartThings app. But you cannot log into it if you have a Samsung account. Only if you have a legacy SmartThings account.


(Joel W) #11

Some of the sites that talk about Side Loading the Google Play store say it doesn’t work with the latest update from Amazon. I don’t want to mess up my Fire HD 8 gen 7 unless I know for sure the downloading and installing the four files will work.


(Joel W) #12

Took the chance and followed the directions and have SmartThings Classic working fine.

The only thing I might have done wrong is on the download page the file to download was listed, and under the download button was in red text a newer version is available below. But the files listed below were older dates, so I wasn’t sure which was newer. Now if there are newer files do I have to install them again? Below is the link I used.
How to side load Google Play store


(Joel W) #13

Found first problem after side loading Google Play store.

  1. When Fire HD 8 7th gen is placed in Show Dock it no longer switches to show mode automatically.

The work around is to press the power button then place in dock. If I am doing something wrong please let me know. I do have the toggle on to switch when docked.

UPDATE: Fixed the problem, had to reboot the Fire, as it was just stuck. Now Show Mode works.


(Scott Moore) #14

I still can not get past the “Samsung does not work with SILK web browser” issue. It is not google play fault. The issue is when you try to log in it says “Samsung does not work with SILK web browser”. I have google play and loaded SmartThings. BUT when you try to use it and log in smart things says "“Samsung does not work with SILK web browser”. I loaded Fully Kiosk too. The Youtube instructions assume you ONLY have to side load Play Store. That isn’t the issue. I cannot find anyone that has gotten Smartthings to work on Fire HD 8 gen 7. I cannot figure out how to make Chrome or anything else besides SILK to be the default browser. Nor can I get SmartThings to work with the Fire default browser Silk. No matter what I try when I go to login to Smartthings it says "“Samsung does not work with SILK web browser”.


(Joel W) #15

II gave up on it, as I haven’t found a way to get it to load.


(Davin K Dameron) #16

I was able to do it just two weeks ago on a Fire 7. I downloaded the Samsung browser app and used it to login. I don’t recall all the steps but I had to keep trying. Silk was disabled on mine.


(Jimmy) #17

How did you disable Silk?


(Joel W) #18

I have tried everything and can’t find how to do it.


(Davin K Dameron) #19

I’m not at my computer right now to find the link, but someone wrote a utility to remove stock apps on the Fire 7. Not sure if it works on the 8. I’ll post the link later when I get home.


(Davin K Dameron) #20

https://forum.xda-developers.com/amazon-fire/general/tool-amazon-fire-7-7gen-fire-os-5-6-x-t3815112

Here’s the forum post for the utility I used. I had to downgrade to 5.4m then I uninstalled the amazon apps and removed the ads from the lock screen. Then I installed Play store and did all the rest.