Smartthings Android App on Kindle Fire?


(Arn B) #1

Enabled the Google Play Store on my Kindle Fire and installed Chrome and Smartthings Android app. ST app refuses to allow a login with the Silk browser, and I’m unable to get the Chome browser as the default. ST support says " Unfortunately we do not support the Amazon Kindle devices when attempting to install the app.".

Anyone managed to get the ST app working on a Fire and if so how?

https://screenshots.firefox.com/jxPuTGinfwm3cC7R/p4.zdusercontent.com


#2

Yes- I used the Updated Fire Utility to install Google Play and associated services, then installed Smartthings from GP.

https://drive.google.com/file/d/0B4GUCBOVtmvPWG9UbWc4S2xpZE0/view?usp=sharing


(Pizzinini) #3

hm… I set this up quite a while ago and I remember that it was difficult but I dont remember how i did it anymore… Only thing I can confirm is that it is working. I will look into it and report back if i find out anything.


(Jimmy) #4

It’s only a problem if you have a Samsung Account login, not an old school SmartThings account. I’m in the account migration beta and it worked fine before the beta. But now that i’m authenticating through the Samsung website i get the same imcompatible browser warning. I tried with Silk, Chrome and Firefox and all 3 give the same warning. It is flagged as a bug in the beta site, but who know if they will actually fix it since its a Samsung wide problem.


(Arn B) #5

Thank you for responding.

Sigh–sounds like I’m using a Samsung login. Any way to make this determination and revert?

What a PITA and really dumb coding by ST to lock out a user if it’s not a “certified” browser! Just say it’s not “certified” and degrade if some feature is not supported, but don’t lock out the user. Besides this is an app, why are they worried about which browser I’m using.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #6

Who knows?

Meanwhile, I bumped into a certain “technical executive” at SDC and he was wondering if ActionTiles runs on Fire tablets - It sure does! Even in Silk.


(Arn B) #7

I prefer using ActionTiles with the Fully Kiosk Browser on the Fire. Eliminates the sleep screen and more.


(Jimmy) #8

Perhaps the technical one that came from Amazon :wink:

The browser restriction could be a crude security restriction. Who knows.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #9

Nope. But I shouldn’t encourage more guessing… :speak_no_evil:


(Mark) #10

I think after a certain date new users had no option but to create a Samsung account. You either had a SmartThings account from before they made the change, or you don’t. :face_with_symbols_over_mouth:


Account issue
(Jimmy) #11

I would guess that cutoff is 5/4/17 based on this beta:


(Timothy Murray) #12

So here we are almost a year later… and still no way to get the app to run on a fire. that really sucks. do you want to know what else really sucks? needing to use a different account to log into and post comments on this site. Especially with the 10 character minimum for passwords. That is just not going to work long term.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #13

This site has been here for over 5 years, with thousands upon thousands of users.
I think you underestimate longevity.

Regardless, once the new App and API are completely rolled out, this Community is likely to be replaced with the one on https://smartthings.developer.samsung.com/- which uses your Samsung login. Which I hate - it is poor security practice to use the same login for something as personal and sensitive as my home as for a chat forum.


(Brad Langhorst) #14

I don’t know what’s worse - the fact that Amazon won’t let you change the default browser or the fact that Samsung’s login process hasn’t been changed by now to either work in Silk OR prompt the user to pick another browser on their device and just use it going forward.


(Mark) #15

My SmartThings account login is a key to some pretty private areas of my life.

My SmartThings community login is of trivial importance.

Why would I use the same login info for both?

How often are you logging in and out of the community website on a desktop or mobile browser? I haven’t had to login to my community account in maybe a year or two?