Problem with ST app on Kindle Fire HD8


(Scott Sharp) #1

Trying to set up SmartThings app on Kindle Fire HD8 (new generation). I have all necessary Google services sideloaded, and have set Chrome as the default browser.

Downloaded, install ST Mobile through Google Play store. When I open it for the first time, I get a screen with two options: New to SmartThings or I’m a SmartThings User.

I am a SmartThings user, so I click on that. I am prompted to enter my email, which I do. Hit Continue.

A browser window opens (us.account.samsung.com). It is an error message that the website doesn’t work with the current browser. It tells me I must use either Samsung Internet, Chrome or Safari.

This obviously is calling Amazon’s native Silk browser to open the page, which doesn’t translate Samsung’s website apparently. But I’m dead in the water. I click the hamburger menu to Open in Chrome, but I get the same page now.

I"ve tried everything. I cannot find a bridge from the login prompt to the app to a functioning Samsung webpage to get logged in. If I open the webpage directly in Chrome, I can get there, get logged in. But the app refuses to make the call to that page directly in Chrome.

Which is rendering this app useless on this tablet.

Has anyone seen this before and, if so, have you figured out a way to make this work?


How do I install the SmartThings app on a Generation 7 Fire HD 8
Amazon Fire 7 and SmartThings (Samsung login, Silk, Chrome?)
(Dave Gutheinz) #2

OK, I was wondering myself. So, I tried using the following:

a. Connected to and downloaded 1mobile app (http://www.1mobile.com/1mobile-market-free-android-store-79873.html.

  1. I had to allow app installs in a security warning.
  2. I also had to all install since it might be unsafe.

b. Started 1mobile

c. Searched for SmartThings Mobile and installed.

d. Opened SmartThing Mobile. Started App. Logged on (successfully).

Device: Fire HDX 8.9 (2014) running latest fire OS.

Dave


(Scott Sharp) #3

Same thing. Must be something in the firmware in the new device.


(Dave Gutheinz) #4

What I understand you are saying is that when you entered the username in the app, the app popped you to the SmartThings Web page (on Silk). It does not normally do that. Could you have the wrong SmartThings username? That might cause this.

I just confirmed this on my Tablet. Logged out of account and tried logging back in with wrong username. It popped me to Silk. Retrying with correct username popped to password page, login, etc.


(Scott Sharp) #5

It asks specifically for my email address. I am entering the correct one. Just checked: User name is the email address on my account.

When it popped you to Silk, did it give you that error message that the website cannot be translated by the browser? The specific URL it is trying to render is us.account.Samsung.com. The first line on the error page reads: SAMSUNG ACCOUNT.

I do have this set up successfully on my Android phone. But I specifically wanted to use this Fire tablet for all my automation, and this is killing that idea.


(Dave Gutheinz) #6

Yes. It gave the error message when I had the wrong username.


(Scott Sharp) #7

OK. I am entering the correct email address, which is what it prompts me for. Doesn’t ask for a user name, nor do I have one.


(Dave Gutheinz) #8

Correct. ST username is an e-mail.


(Brad) #9

Samsung Account logins are incompatible on Kindle Fire. If you have you sign into ST via Samsung Account, it won’t work. The ST App isn’t officially compatible with Kindle Fires but we are aware of the issue,


(Scott Sharp) #10

I would fully understand if there was some real incompatibility with the functioning of the app. But it seems silly that I can’t use it simply because I can’t get logged in.


#11

I was just about ready to make my own thread, when this thread was suggested. I’m having the exact same problem and am going to follow.


#12

I read that you might have to change the default browser. I installed Chrome, but I cannot figure out how to make it default. The instructions I found say that on the Fire to go to the home tab and click web, but I do not see anything labeled web.


#13

Another thing that seems inconsistent, Amazon sells hundreds of Smartthings products, but there’s no native app for their devices.


(Scott Sharp) #14

There is no setting I can find to set anything other than Silk as the default browser.


(Scott Sharp) #15

I believe that is the choice of the app developers, not of Amazon.


#16

Scott_Sharp, I think you’re right on both accounts.


(Dave Gutheinz) #17

The browser issue aside, has anyone (except me) been able to install and log into (as an existing user) the SmartThings mobile on Fire (already having an account and installation on an android/IOS device)???

(changed after first response)


#18

I successfully installed the Smartthings app on my son’s Fire, but I cannot log in.


(Scott Sharp) #19

Not exactly. It tries to pop me to the Samsung account web page, using Silk. Apparently now, since Samsung purchased SmartThings, you have to use a Samsung account – which is impossible with Kindle Fire. Is your account a legacy ST account (as opposed to a Samsung account)?


(Dave Gutheinz) #20

I believe it is legacy. So maybe that is the issue. Sounds like a ticket should be issued to ST customer service. (I got my account in Jan 17 and already had a Samsung Account (same user ID). Never popped me to Samsung in setting up account.

Ticket would read: “When logging onto the SmartThings Mobile App, the system pops me to the Samsung internet page to log into a Samsung account. Other users go directly to the SmartThings login. Is this a “FEATURE” or a bug?”