Fire Tablet SmartThings App (from google play) Login Problems


Does anyone know a workaround/ solution for the subject issue.

When the SmartThings app pushes you to the silk browser, the browser cannot authenticate the login.

I would like to use the fire hd 10- 7th generation that I own to maintain my SmartThings setup. (If I want strictly device control, I would simply use actiontiles)

The only caveat I have, is I would like to use the ask Alexa handsfree that was added with fireOS VERSION 5.6 I believe.

Thank you all for any advice/ help you can give me with this problem.

I can log into the ST app with no issues on my Fire 7.

yup, common problem if you joined after May of 2017. That’s when SmartThings started using Samsung Accounts and the Samsung Account authentication page does not like the Android 5.0 that Fire OS is based on. I’ve tried multiple browsers and nothing works. My suggestion would be to email support so they are aware this is becoming more of an issue. Hopefully they pass it on to their colleagues at Samsung. Maybe @Brad_ST is aware if they are communicating this?

1 Like

I was under the impression that Alexa wasn’t hands-free on the tablets. Am I incorrect?

You probably joined before May 2017 and have a SmartThings login

She is not except for the 10" maybe?

1 Like


What a bummer. You would think with the interoperability of the 2 brands that this interesting problem wouldn’t exist…

So I can control SmartThings with Alexa but not with an Alexa tablet… Just seems inconsistent

Is there anyway to remedy this?

I use Alexa handsfree on the 10” newest version.

ActionTiles (web/browser based app for viewing and controlling your Things) works fine on Amazon Fire Tablets; even in the native Silk browser; though a lot of folks side-load Fully, Chrome, etc…

Maintain= Full SmartThings App functionality
Maybe I should be more specific next time :slight_smile:

1 Like

Nah… I just overlooked that, sorry! :no_mouth:

We’re certainly not trying to exploit the overall incompatibility of the SmartThings App on Fire Tablets; it’s a rather sub-optimal situation, because these are very popular tablets, and SmartThings App now has a “tablet mode” too.

We just hope that ActionTiles can fill a part of the gap.

Yeah I am very happy with Actiontiles.

Def a great general use system for device control with SmartThings.

Very impressed with what you all have built!

1 Like

Thanks, Weston!

Not really that simple in terms of interoperability. Fire as an OS is different from Alexa as a service. Similar to Google Home as a service being separate from Android as an OS. Doesn’t make it less frustrating though.

1 Like

True. Thank you for that thought. Very nicely put.

1 Like

So here’s something interesting. I got a new Fire HD8 on Black Friday and just set it up. I installed the Google play store, chrome and smartthings. Followed a web link from another app and set Chrome to always open. Tried smartthings and sure enough it worked this time opening via chrome. No clue why the same thing didn’t work on my 2015 7" Fire.

1 Like

Have you tried your old 7" again? Perhaps SmartThings fixed the glitch (and/or some recent update to FireOS has changed the behavior…).

My old 7" worked … well… but that was with an old version of the SmartThings App and a non-Samsung login … so… :confused:.

That would be so great if this glitch was gone. Could you tell me what fireos version you have on that specific tablet?

Also, could you tell me what app you were opening a link from and I’m honestly going to do the identical thing that you are speaking of.

I hope this issue is no more but I was just working on this a day or so ago and it was prevalent. Maybe if I follow your steps exactly. It would disappear.- fingers crossed.

So I’ve tried everything “half passed Sunday” and I’m still getting the same result of silk opening the links. It must be a firmware difference between our devices- that’s my guess at least.

I went one step further and used the “clear defaults” button within the application in the “manage applications” setting menu for the silk browser. This was in hopes that the next time I selected a web link that it would ask me which browser I would like to use to open the link and it still defaulted to Silk and have me no option to change. I’m at a loss at this point in what other things I can try.

Maybe your info will shed some light on what’s going on.

Lastly, as others have stated, did you sign up previous to the May 2017 date? If so that’s automatically why yours works even on a new device.

Thank you in advance for your responses. Maybe I’ll get lucky and something will work.

I haven’t tried the 7" again. I deleted the play store and everything off of there to convert to use for my daughter. I’ll check OS version when I get home. I know it did update to the most recent last night, so maybe i’ll play it risky and try logging out and back in now that the OS is up to date. It almost sounds like something isn’t getting cleared when you remove silk as the default browser.

I signed up well before May 2017, but i’m on the account migration beta, so I have a Samsung login.