How do I add this SmartThings outlet (UK)

I’ve just found a SmartThings outlet (UK) so thought I’d use for the tree lights.

It’s never been added, but when I go to add device I don’t see it listed.

It’s the small square-ish one, it doesn’t have a model number on it. It has a little button and LED on both sides to switch it on and off.

Any help please?

Looks like this
https://business.currys.co.uk/catalogue/cameras-smart-tech/smart-tech/smart-home/samsung-smartthings-power-outlet/N144876W

You may need to reset it. Hold in the little button as you plug it in/switch it on. The blue light should blink slowly showing its ready for inclusion, then you’ll be good to go.

1 Like

Thanks I’ll try that now. But which model do I chose on the list when trying to add as not sure which to choose.

No blinking….
Tried when plugging in and holding for more than 10s and just stays on with a blue light

Try these methods too:

  • press and hold the button while plugged in until the LED starts blinking.
  • press the button 5 times fairly quick. sometimes 7 or 10 times are sequences that work to reset a device. this is not a sure thing, but you’d be surprised what’s not documented.

Instead of selecting a model when trying to join, select the option Scan Nearby.

Tried above as well and the LED just stays on.

It seems I can’t get it into this pairing mode. I’m sure this is an official SmartThings power outlet as well, or Samsung one but doesn’t have any branding on which is strange. I can’t remember if I got it in the starter kit years ago or not.

This is it…. It has a button on either side, I’ve tried both together. Each side etc

It sounds like when you hold one of the buttons in when powering it up, the LED turns on. That IS the reset indication for a Centralite Series 3 plug which looks remarkably like yours, and Centralite did make plugs for SmartThings. Have you tried pairing it from that state, or did the lack of blinking deter you?

You can just use ‘Scan Nearby’ in the app. Choosing specific devices is more elegant, but is pretty much equivalent in many cases. As long as you aren’t being prompted for specific information it often doesn’t actually matter which device you choose.

The LED turns on whenever you press the button, or hold in the button. I presumed to show it’s on. Tried the scan nearby but still doesn’t see it.

I always presumed you had to be in a “pair mode” to get it added in ST app though.

It was originally in the starter kit here’s a video I found on YT with it. Around 4:40 can see the exact one I have.

On the box it states a smartpower outlet.

At last….

Got it connected and in pairing mode.

I had to plug it in while holding button, as soon as LED came on I had to release and it flashed and found using scan nearby.

It’s not very intuitive, why not just hold in button for 5/10s to go in pairing mode?

Anyway added and working now.

Yeah, just like i said…:blush: