How can I add Iris Thermostat CT101

SmartThings newbie here switching from Iris. I have an Iris CT101 thermostat that it sounds like people have added. Just installed my SmartThings home monitoring kit and some Iris devices are coming over just fine. Anyone know what steps I can take to get this thermostat connected? It’s not on the list of devices to add. Thanks in advance.

1 Like

Just choose any zwave device and then put it in pairing mode.

Is that in the classic app or the new one?

New. Classic you can just choose add device.

And make sure you exclude it first to reset it.

Can we then move the device from classic app to new app?
Does the thermostat have to be disconnected and next to smart hub to pair?

Got it setup, thanks all.

I had Iris since the beginning of Iris, I have tons of 1st gen sensors etc, I also have a CT101 thermostat. I bought a Hubitat Hub because I could keep my 1 gen devices, later to learn I could keep them, pair them, and look at them but that was about it. My thermostat is paired and I set up a schedule which worked for about a month, now it keeps getting confused and changing the temps. Anyway, my question here is should I dump the Hubitat hub and get a ST hub? it seems like you need to be a programmer to get Hubitat to do much of anything. Iris may have had it’s problems but it worked, right out of the box, no programming language needed. I’m looking for a system that is as easy to use as Iris was.

I think the general consensus is SmartThings would be between Iris and Hubitat on the ease of use scale. But you’d have to get new sensors because the Iris gen 1 sensors don’t work with SmartThings.

Thanks, I ordered a ST WiFi Hub today and guess I’ll keep the Hubitat for my Gen 1 stuff until I can replace it. The ST looks like it will be interesting.

I’ve tried all suggestions I’ve been able to find and can’t get my CT101 to pair with my gen 3 hub. Have tried both classic and new apps, am ready to ditch the thermostat all together but feel like it should be able to connect. Have reset the CT101, have moved the hub to within a few feet…anything I’m missing?
Thanks in advance.

Did you exclude it with SmartThings?