CT101 pairing difficulty (v1 hub) partially working


(Chris Roberts) #1

I replied to another topic with an initial question related to difficulties I have had with getting the Iris CT101 thermostat I picked up on Amazon.

But now feel this is due for a separate topic.

I did actually manage to get my thermostat paired once. I tested it out using the SmartThings provided CT100 device handler. All worked good except I did not have C wire connected for that pairing process so it didn’t get paired using the desired Zwave mode…

The pairing process I took was insane and no idea what actually made it work except that at one point halfway through factory resetting the thermostat Smartthings in “add a thing” mode finally found it…

All worked but as I said it was in battery saver “beam” mode… So I removed the device from Smartthings and did the exclusion process as well. Rewired it to use the C wire and ran into same issues getting it paired.

After several Zwave repair marathons I finally noticed something in the logs. Each time I tried to Link the thermostat to smartthings the thermostat would say it linked but smartthings never saw it. But later when I did a zwave repair, I noticed in the event logs it would find an orphaned device (id 43 the first time) I got rid of it and tried to pair again. No good. Another orphaned device (id 44 this time.). Repeated the remove/exclude/pair process again (id 45 now.). But this time instead of removing the orphaned process I created a device in the IDE and gave it id 45 with the ct100 device handler.). This worked for the most part and I could control the thermostat and get data back but I never got the proper zwave raw data in the device info page on IDE and each time I tried a zwave repair it always reported that that device couldn’t update the mesh (I tried about 5 times to repair …)

Any thoughts on how to get this thing to pair properly???

I’ve got a radiant heat setup with a thermostat in every room. The high cost of simple zwave thermostat has prevented me from pursuing it but these CT101 thermostats are actually affordable now! I would like to replace more but not if this is the nightmare I face each time I want to add one.


(www.rboyapps.com - Make your home your butler!) #2

A few things make pairing this thermostat easy

  1. If you have the Z-Wave version make sure it’s within about 30ft of a Z-Wave plus mains powered device or the hub. If it’s further than that it will have a lot of trouble pairing. Note this only applied to the older Z-Wave thermostats and you will need a Z-Wave PLUS mains powered device close to it (Z-Wave mains powered device don’t help with pairing, only plus devices do)
  2. Reboot the hub before your try to pair it

(Chris Roberts) #3

Thanks. Yes it’s the zwave version of thermostat. I have tried this with both a zwave plus device next to thermostat and the hub physically next to thermostat. The result is always the same. The thermostat says it paired but smartthings does not see it in the app. If I do a zwave repair after this the event logs will report an orphaned device which is exactly the device I was trying to pair. It’s like smartthings stops halfway through the pairing process and leaves the job partially done.

I have rebooted the hub just about every time I tried to pair the device. I’ve also done numerous clean runs of the zwave repair process along with reboots before pairing.

And so it’s not lost I have in fact paired this thermostat once already successfully in the app. I didn’t have c wire connected that time tho. I can also manually create the device and communicate with it but I am not convinced it’s 100% when I do it that kludgey way.


(www.rboyapps.com - Make your home your butler!) #4

Hmm orphaned device is not usual. @tpmanley any thoughts?


(Chris Roberts) #5

Thanks :). Looks like I’ll give Smartthings support a crack.

I have it paired the kludge way right now but updates seem to only occur randomly or if I go into configure the device in the app and pressed save. After I pressed save it seemed to register numerous temperature adjustment presses at once and set temp to 85 which is not good.