Honeywell YTH8320ZW1007/U - Communication Lost

I am new to SmartThings and recently installed two Honeywell YTH8320ZW1007/U thermostats. One works fine and the other shows “Communication Lost”.

If I pull the thermostat from the wall and re-install, it will work for a little while and then quite. The thermostat is probably only 25 feet from the hub, so it should not be a range issue.

I have also tried:

  • Remove the device from the hub, re-setup
  • Resetting the panel (remove from wall, pull battery)

Should I return thermostat and get another. The problem with Smartthings or the thermostat?

Thank you.


Is this thermostat used more often for manual overrides? I noticed that one of mine loses connectivity every time I manually change the settings. I have no connection problems as long as I use ST…

I’ve got the same thermostat and ran into same issues . Try removing the thermostat and then removing the battery as well. Let it sit like that for 10 mins or so before putting everything back. Another thing you can try is to fiddle with the zwave card on the side. For that you may have to pull off a plastic cover which you can do without. Try pressing it in so that it makes good contact within the slot.

Based on reviews and what I have read, it seems like Honeywell just has poor quality control. Since mine is relatively new, I am just going to replace it. Amazon is sending out another one at no charge. Hopefully I will get a good one and it will last.


1 Like

Please come back and update if that fixes your problem…

@phillipl @SBDOBRESCU @ashutosh1982 , there are a few other posts in the community about this. I started having this exact same issue on BOTH of my Honeywell thermos several months ago. There are also many posts in the Vera forums about these thermos with the same problem. They are poor quality.

The problems started happening just once or twice, but it got to the point where they would drop off every day, even after completely resetting them to factory default and reincluding them back tot he hub. Honeywell was useless in their customer support, service, and willingness to help. They were the most difficult and frustrating people I have worked with for a very long time.

I ended up putting them up on a target range, and used them for target practice and aligning my sights for hunting season…

They were replaced with Evolve T100r’s, which have been flawless since day 1.

Man can someone give me a good news today? :smile: Just ordered z-wave outlets to replace my POS wemo insights…

How about that it’s Thursday, tomorrow is Friday, and so far we haven’t been told of a platform upgrade for Saturday to keep us busy finding new poltergeists on Sunday?

1 Like

That certainly doesn’t mean anything. We didn’t hear anything for the past 4 weeks and it happened. I am bare rooted now. 4 routines and a handful of smart Lighting instances. I am ready for this Saturday…No more Wemo, Hue, Sonos, Echo…what’s the point?

1 Like

I installed a new / replacement thermostat and the same thing is happening. Not sure if it due having two thermostats or the location of the hub. I am going to try moving the hub to another location next.