Honeywell TH8320ZW thermostat communication problem

I installed a Honeywell TH8320ZW thermostat and connected it to my V2 Hub without issue. It worked for about 1 hour and then the thermostat indicated ‘Communication lost’. The thermostat is working fine, but I have no control from ST. From ‘My Hub’ > ‘Z-Wave Utilities’ > ‘Repair Z-Wave Network’ I have repeatedly received this message ‘Network repair for Z-Wave Thermostat [OA]: Failed to update mesh info’. Thinking that removing the thermostat from my system and reconnecting it would solve the issue, I attempted to do that. The removal attempt on the thermostat produced ‘The Action Failed’ message. Any thoughts on the next steps I should try?

@wajans, I use to have 2 Honeywell thermos, but I got rid of them as soon as BOTH had the same communication lost message on a daily basis. That seems to be something common with Honeywell, and not just for ST users. Vera and other hub users have seen the same message on their Honeywell thermos on their hubs. One of mine was only a few months old, and only 6 feet from the hub, and it still lost communications every day. Also, Honeywell’s support was the worse experience and least helpful of any company on the face of the earth I’ve ever had. Dropping my AOL subscription back in the 90’s was a better experience… Anyway…

I’m going off what I use to go through on a monthly, then weekly, and then a daily basis with these thermos. If I remember right, the “Action Failed” message is common with Honeywell when trying to exclude it. It actually doesn’t remember ever being connected to a hub, so try joining it back to ST. OR, it’s not seeing the hub’s general exclude command request, so try that again. Start the general exclude process first, and then start the process on the thermo.

I have had good luck with ct100 and custom device type if you are looking for a zwave alternative.

After much communication with both Honeywell and ST support, it was determined that my thermostat was defective. I have received and installed a replacement from my supplier and the connection is fine at this time.

That’s great to hear, especially since Honeywell actually worked with you. Hopefully they fixed the underlying issues that cause the communication lost issues.

Just for the record, I am on my second Honeywell RTH8520ZW from Amazon. Not sure of the difference from 8320 to 8580. The first was returned after LCD display issues and replaced at no charge, this time I’m leaving the light off just in case. Both of them have never had communications issues and worked flawlessly.

I tried several device handlers and settled on @jscgs350 My Thermostat v7, which I now see has been updated to v8.

EDIT: Updated link

Thanks for the info on the @jscgs350 My Thermostat V8 device handler. This is the 1st time I’ve tried to set up a custom device handler. Installation seemed pretty straight forward and the up arrows in the app work fine, but when I use the down arrows the heat jumps immediately to 32C and the cool to 37C. I’m not sure if the fact I’m using Celsius instead of Fahrenheit has anything to do with it. All the other controls are working. I don’t have much experience coding, but from my survey the code all looks fine. Because this device handler works on your Honeywell TH8320ZW I would expect it should work on mine as well. Anyone have any suggestions?

Are the sliders working? I upgraded to v8 but haven’t tried it yet. We are in Arizona and our unit is off now. I will play with it and see what I get.

As soon as I move the heat slider it jumps to 32C and the cool slider jumps to 37C. I really don’t care if the sliders are working. I went to this device handler to get away from the sliders.

Hi @wajans,

I updated the device handler to move the sliders and arrows around, and to make the temperature reading larger by removing the icon because, well, that’s what my wife liked…

Everything is in Fahrenheit, but I will change that. I’ll fix that now, and in fact I shouldn’t have limited it to “F”. That is my fault.

Stay tuned, I’ll be right back!

Hi @wajans, @Whippm,

This update removes forcing units to “F”:

Would you mind giving this version a try please?

1 Like

Thank you so much for doing this update johnconstatelo! Unfortunately the heat down arrow still causes the heat setting to go to 32C and the cool down arrow sets the temp to 37C. The sliders are now working fine, although at 20C they are all the way to the left, making temperature adjusting difficult. Not that I want to be picky but because 1 degree C is a larger unit than 1 degree F, is it possible to use 0.5 increments? That’s what the thermostat itself uses.

The range feature is in whole numbers, so it’s probably best to not use a range. Let me change that part of the code and look into the down arrow issues. Be right back!

@wajans Can you try this again? The down arrow issue should be resolved.

I need to look into the 0.5 increments for the up/down arrows, but I don’t think that’s possible.

1 Like

Thanks @johnconstantelo for the continued support of your device type. I don’t know why some people have problems with the Honeywell ZW thermostats, I have never had a problem other than a minor display problem with the LCD.

I updated and everything works in F and I see the first decimal place now, but is is always “0”, even the current temp. The sliders now seem to have full range but the thermostat reports them back to 40 and 99 default. My thermostat must not support decimals even on the panel.

Working wonderfully! Up and down arrows as well as sliders are doing just what they should be doing. Thank you for the timely and effective fix johnconstantelo! Much appreciated. And whole unit increments are certainly functional.

1 Like

Try something for me? I ran into this last night. Please clear your browser history for this:

I just made a slight change, and added “02-17-2016” under Updates so you know it’s current. I removed all references to any range and up/down arrow limits (this may have bitten you).

Also, make sure to tap on the Configure tile in the app.

Very pleased with the way this is device handler is working with my thermostat!

OK, updated device type, cleared cache, works the same. Here is what I see going on after playing with some system setup functions on the thermostat. The parse returned value is the “function 0600 - Heat Temperature Range Stop” and “function 610 - Cool Temperature Range Stop” as user configured on the thermostat:

8:14:16 PM: debug Parse returned [[value:74.0, unit:F, name:temperature, isStateChange:true, displayed:true, linkText:Thermostat, descriptionText:Thermostat temperature is 74.0°F]]
8:14:16 PM: debug Unit is Off.

This appears to be a normal function and returns the limits of the unit.

In addition, after reading other threads in this community, it appears that most thermostats in this class (CT100, Honeywell ZW) only support whole numbers if the unit doesn’t display them. There are a couple of the very newest thermostats coming out that will support decimals.

Could you please remove the decimals since they aren’t reported? The latest Android ST app handles text bad enough and the numbers go outside the circle. Thanks again for your support![quote=“wajans, post:16, topic:34356”]
And whole unit increments are certainly functional.

Hi @Whippm, that’s interesting on what’s coming in your live logs. Here’s a snippet from mine:

Parse returned [[value:68, unit:F, displayed:false, n

That change should be easy, so give me a bit to look into this?