Honeywell Total connect app gets invalid token

I have used the TCC SmartApp before but now it is not working. When trying to enter credentials I get an invalid token error. Is there a fix for this? Can the app be removed and reinstalled? Very frustrating after all the expense of the thermostats.


I had to reconnect it to ST. New app…hit 3 bars…gear for settings…linked connections…and enter your credentials.

Okay, not quite sure I understand. Can you explain in more detail? anyone else have Honeywell WiFi 9000 thermostat issues with SmartThings?

Go into the new ST app…upper left there are 3 horizontal bars…select that for settings… next screen …upper right is a gear for settings…,select that…go to linked connections…select it…select TCC and reenter your information and save. It solved my error issue. Hope it helps.

Okay, well I am using the classic app. I vaguely remember some things I have Do not work correctly in the new app. Something I need to revisit.

If you still see the thermostat device in the app, you shouldn’t need to re-enter your credentials. In the Classic app, if you go to Automation --> SmartApps --> Honeywell TCC (Connect), then what are you tapping? If you see “You are connected.” you can tap “Next” to select your thermostat.


Honeywell is not working anymore just says off. I tried reconnecting through the smartapp . That worked OK. But all therms just say off. See attachments.

I am tapping “click here to enter your credentials”. All thermostats show “unavailable”. If I go to the thermostat in “My Home” and tap RECENTLY it tells me to renter credentials. Has to be a credential issue because all thermostats are not working (all the same exact thermostat and worked before). I go to change credentials and get the invalid token error. I try to remove the app and it tells me “an error occurred”. That’s it. So I’m in a catch 22 loop here with no way out it seems. Honeywell web site works fine with thermostats.

@Lgkahn - I assume the thermostats are in fact on? What are your setpoints? Is it possible that you’re hitting the deadband with the cooling and heating too close together?

Thanks for the additional info. I was able to reproduce this by de-authorizing SmartThings on the Honeywell TCC portal. There is a similar open bug report and I’ll add this additional information.

If you go to, do you see SmartThings listed under “Subscribed Applications”?

In terms of resolving the issue, if you are only using the Classic app, I believe if you delete the thermostat devices you should be able to remove the Honeywell SmartApp. Alternatively, in my experience I was able to remove the SmartApp from the new app under “Linked services”. If those aren’t options or don’t work, ST support can remove the connection.

Once removed, there shouldn’t be any issues re-adding the integration.

Ac and heating are on separate thermostats. Of course the thermostats are on.

I do not see smartthings there, just the rooms where I have the thermostats installed.

That was directed to Larry.