Honeywell RTH6500 Wi-fi Thermostat HELP?


(Lisa Marie) #1

New here, hoping there’s some help here. Trying to connect a Honeywell RTH6500 Wi-Fi thermostat, I get to the Honeywell TCC (connect) screen where you’re supposed to login to the Honeywell App but when I click on “Click to enter your Honeywell Credentials” I get an error:
55ece109-1ad7-4172-a580-45712fbebf81 invalid_token

Anyone know what’s going on or have a workaround??

Thanks in advance. L.


(KC ) #2

I had to contact honeywell tech support and have them manually input macID and crcID from thermostat in their database then everything worked. Of course my thermostat was different model but you might give that a try.


#3

I’m gettig this error now too.

Mine has worked for months. Woke up this morning and it wasn’t working with SmartThings.

I opened the SmartApp to try and sign in again and get the same error.

Hopefully it will be ironed out


(Axel Granholm) #4

I am having the same issue.


(Matt) #5

I am having the same issue as well.
In an attempt to fix it I tried to remove the smartapp but it would not let me. So i removed both thermostats as devices and it still won’t remove.

I really dread calling Honeywell support.
AND adding all my stuff back for the thermostats.

What broke this?


(Matt) #6

I talked to ST support. They are aware of this issue on the NA 02 server.
I asked them up update the thread. They have no ETA.