Honeywell Thermostat Partially Working

I’ve got the Honeywell RTH9580. With rare exception, its worked great via remote controlling on my Android phone via the Honeywell TCC app. However the smartthings integration seems problematic. At first I thought it was working in “read only” mode within smartthings… but it turns out, that from smartthings, I can indeed control the FAN settings (which I rarely do) , but cannot control the temperature. Any ideas? I dont have much hair left to pull out!

I know this doesn’t help you but I was plagued with Honeywell integration problems via smartthings. It only worked half the time. I was patient with it for over a year but I couldn’t take the constant failures to keep the thermostats (4) in the correct state.

I moved to ecobee 2 months ago and haven’t had a single problem since. The UI for both manufacturers in Smartthings is the same but the one for ecobee is way more reliable.

Again, I know this doesn’t help you now, but 6 months from now when you’re still pulling your hair out, please consider the way the Honeywell integration behaves in ST is not normal.

I have a Honeywell Prestige IAQ model and also use the Honeywell TCC app.

I try to not use SmartThings to control the devices attached to it as much as possible, so I just noticed what I’m about to explain recently. I have many devices attached to ST, but try as much as possible to control them via webCore, Rule Engine, SharpTools, etc. For things that have their own app such as TCC, if I need to control them manually, I use the native app.

Even though I didn’t use the functionality, under the Classic app, I could control the thermostat . . change the temperature, etc. Recently, I realized that under the new app, it appears to be the “read only” functionality you described. You can read the temperature, see the state and see some history, but that’s about it.

But even though there is no functionality in the UI to control the thermostat via ST, ST still exposes those things for control by external connected apps like webCore, Rule Engine and SharpTools. Kind of weird, but that’s how it is.

So you can still automate things like setting back the thermostat upon departure. You just can’t do it via ST natively.

1 Like

delete and then repair Honeywell. Ive had to do this several times over the past few months. The issue is on Honeywells side …there servers have been wonky for months even on Google home where I have a direct integration outside of Smartthings.

1 Like

Tried reinstalling. Also tried installing an older version of the smartthings app, based on suggestions on a different forum… nothing seems to work. Actually, I orginally noticed the problem on my Sharptools interface… but best I can tell, sharptools is only a portal to access Smartthings… forgive me, I’m a novice! So it seems like the underlying problem is smartthings interface with honeywell, nothing that I’ve done wrong… ugh…

1 Like

did you remove Honeywell from the linked services page or just delete the thermostat from the main page?

1 Like

Yes, SharpTools does access devices through SmartThings, but as I mentioned above, it can access everything that ST exposes, regardless or whether or not ST allows you to access them natively. For example, I have a thermostat icon on my SharpTools dashboard. I am able to adjust the thermostat setpoint via the SharpTools icon even though you can’t do that through the ST UI.

Do you have a thermostat icon on SharpTools that isn’t working?

1 Like

Yes… I have the same problem with Sharptools. I can see the thermostat, but in read only mode. I can’t change temp

Open the tile in the Tile Editor and look at the security options, if any. Make sure that you don’t have the view only attribute set.

I thought you might be on to something… I opened up the Tile editor… and security option was not checked… I checked the “Control” option … and just like from within Smartthings, I can control the FAN, but not the temperature!

I’m not sure what the “Control” option is. Here is what mine looks like. You might want to post over in the SharpTools forum, although @joshua_lyon may comment here as well.



1 Like

Bry: This was my experience. I linked the thermostat to ST but not Google Asst. It displays in both and I control it by commands through GA.


Once I select that Security Box, I get options “Control” “View ONly” and a few others . I would assume I want the ability to Control my thermostat (ie change temp), unless those labels are grossly misleading

When I opened the Smartthings mobile APP first thing this morning, it had no thermostat data at all. Now, it has the data, but gives me an error when I try to change the temp. I can successfully change the fan settings! Also, unless I am missing something, there is no point to try to fix this problem from within Sharptools, unless I first have the Smartthings App working? Isnt the root of the problem some communication issues between Samsung and Honeywell?

Ok, I see that now. I don’t have security turned on, but I just did and the tile works the same. With Control enabled under Security, I am still able to adjust the thermostat from the tile.

Can you post a pic of your tile?