Controlling Honeywell thermostat in new app

Are there going to be changes in the future to be able to control this thermostat? Right now I can’t control anything including mode or setpoints

This screenshot is a stock DTH.

Which thermostat model? Wifi or Zwavw? My Honeywell wifi shows all temp and modes info in Smartthings. You could try deleting Honeywell and re-adding or their could be one of Honeywell’s numerous server issues going on.

It’s the RTH6580 WiFi. I can create pistons in webCoRE to change setpoints and resume program, but I would think all of that stuff would be available in the ST app as well.

I don’t think it’s anything with Honeywell servers, because I can still execute commands with webCoRE.

it should be… try clearing the apps cache and force close, then reopen and see if it’s there

I’m using a HW Z-Wave 8320 with the stoch DTH and everything is there.
+1 on cache and storage.

Is app cachet and storage an android thing? Because I have an iOS iPhone.

Try deleting it and setting it up again. The ST setpoint bug was fixed last week but some folks need to delete and setup the integration again.

Also it appears that Honeywell was having issues with their server causing some controls to go missing. If it’s still missing after setting it up again I would recommend contacting Honeywell.

So I added it back to ST and now I can’t select it to use in your app. I can select it for an automaton, but your app says I don’t have a thermostat.
EDIT. never mind. I had to update your app in the IDE.

I have been having the exact same issue. Used to be able to manually control through my st app but now I can’t. Oddly, all my routines and automations still change the temp as they should. @eric182 we’re you able to fix this?

I’m sorry, what exactly is your issue? Make sure you have the latest release of Rboys app. That’s where I would start.

I have the same issue you posted about two weeks ago where my Honeywell wifi thermostat is showing the temperature but not letting me manually control it, yet other routines to control it automatically still seem to function. I’m not familiar with rboys, never have needed it before.

For anyone with this issue and the model I have, (RTH6580WF) I was able to fix it by, in the ST app, deleting the device and adding it back, however the device is not available as a thermostat under “Honeywell“. But a little further down, I added the device “Honeywell total connect comfort”. After going through the prompts it was available again to manually control.

This is the first time I have needed to set it up in the new app, as in the old one I believe total connect comfort would have been added as a “smart app” and not a device.