Honeywell Thermostat installation

I was looking on the forum and in the FAQ site of the smartthings and could not find how to exclude and then include the Honeywell thermostat.

Anybody knows where I can find the instructions?

Thank you for your support. So far this forum helped me get up and going with the Smartthings and happy camper (almost) :-).

@SFBayArea_OLD, are you specifically using Honeywell’s zwave thermo (YTH8320ZW1007/U)?

If so, then it’s pretty simple. Once you start a general exclude in the app, on the Honeywell thermo you’ll need to get into Installer Setup mode and change the value for rf10 to 0 while SmartThings is in exclude mode. SmartThings will say it removed a device. It will not give you any more details than that.

Once excluded, the process is reversed. In the app, Connect New Device, and on the thermo change rt10 to a 1.

In the PDF linked below, look at page 6 to learn how to get into Installer mode, and pages 10-13 for the zwave settings.


1 Like

Press the system and then release. Press and hold the middle empty box to in advanced settings. Use the arrows till you see CF 10. Select 0 to exclude and 1 to include. PM me if you run into issues

Thank you guys. I followed your instructions. I got to the rF10 and it’s showing 1 and 18 higher up. When I press arrow down to go to 0 thermostat showing dashes instead of 0. Smartthings was not able to find it to exclude : -(

When you press arrow down to 0, you need to be in general exclusion mode. When the exclusion worked, 0 becomes the default. Then you put ST in discovery mode and press arrow down to include.

Him, I was in general exclusion mode when I was pressing arrow down.
I will try again.

OK, I just tried it again. Here is my steps:

  1. Press system
  2. Hold buttons to get into system mode
  3. Once in system, scroll down to rF10
  4. Activate general exclusion on my phone
  5. Press arrow down on thermostat
  6. Thermostat showing dashes and a message: "the action failed ".

I have two thermostats, one went very quick, the other…was very stubborn. I think I had tried at least 10 times to get it to cooperate. If you cannot make it work, your last resort is to bring the hub closer. I know…painful. Hope you don’t need to…

Yup, you may be out of range. Keep trying, you are right there

Do you have any other z-wave near by? If you do, run a z-wave repair.

Actually, before I switched to Smartthings, my thermostat was showing out of range. Could that be the problem?
In regards of the distance, the thermostat is much closer then some of my light switches.

Yes, that is the problem. I am not sure why, technically speaking, but inclusion is much easier when the device is very close to the hub. Then you can move it away and would work with no problems. I ran into this problem with one of my locks.

Hm. I am really not sure how to get it close. Smartthings on the second floor and thermostat on the first floor. :-(.

Thank you for the help and support.

If you plan on adding switches or other devices that can be repeaters, I’d do that soon. If not, get one of these:

GE light switch is a repeater, right?
I have it right under my thermostat.

Yes it is, and that’s good. I use to have Honeywell thermos like yours, and if I remember right, the “action failed” means the thermo didn’t exclude from anything because it was never included for some reason. Let’s see if we can get this working for you:

  1. Did the app ever say it successfully excluded a device? If not, no big deal.
  2. Since your last post, have you tried those same steps, but this time in the app first go to Connect New Device and then change rf10 to 1 on the thermo?

Please give that a try again and use the PDF documentation for the thermo to make sure you follow all the steps.

Have you tried reversing the steps 4 and 5? Press the arrow down to select 0 and then kick the general exclusion. Worst case scenario buy a wi-fi to ethernet switch and take your hub closer. Chanses are that once you get it going, you’ll not have any problems, especially with a switch right there. I have the exact scenario here. Oh, and do the zwave repair once or twice before you try again.

Will try it today and report back.

OK. Tried it few more times today, reversing the order of 4 and 5. The thermostat still reads “connection lost” at the top of the screen.
RF10 still showing 1 when I get to it and when I press arrow down it’s showing dashes instead of 0.