Honeywell Resideo Linked Services Help Request

I have three Honeywell/Resideo Wi-Fi Thermostants. I have had them connected to my ST app for years (Pixel 6 Android phone). There are two Honeywell apps, Total Connect Comfort, the old one, and Honeywell Home, the new Resideo. For years, I’ve been connected to ST through the TCC app. Whenever I try to connect my thermostats in ST using the newer app it never finds any thermostats (even though that’s the separate app I use to control them). The ST updated in the last day or two. My thermostats were disconnected in Linked Services. I reconnected using the TCC app. However, I thought that I’d try the new Honeywell Home linked service so I disconnected the TCC app. When I did, it disappeared as an option. How can I get it back? The Honeywell Home option is still there, but it can’t find my Thermostats. Suggestions? Thanks.

I would delete all connections to Honeywell in ST, then do add devices by brand. I have the following options in the US. I personally use Honeywell Home.


OMG, that’s it! I never thought of that. I have them all back. I just added TCC rather than deleting all links, but now that I know how to fix it, I might delete all links and try Honeywell Home since that’s the newer app (although the actual separate app I have is named Resideo). THANK YOU!


I’ve also got three Honeywell WiFi thermostats, the Vision 8000 model.

Same thing with the two apps and two different integrations to SmartThings. I use the newer Resideo app but the thermostats are accessed thru that app connecting to the TCC service. Only the Honeywell Home Total Total Connect Comfort integration to SmartThings works to bring the thermostats into SmartThings.

1 Like

Glad I stumbled on this thread I have a Honeywell Wi-Fi thermostat that until today was not connected to SmartThings. Thanks rcbjr2 for posting your questions.


Going to jump in here for clarification, as my question relates.

I presently have a couple Honeywell RedLink thermostats that use the Honeywell TCC app. I have them linked to SmartThings, principally so that I can query the thermostats through SmartThings for a SharpTools dashboard.

I am adding another location where the builder has proposed Honeywell T6 Pro WIFi thermostats, that according to my research use the Honeywell Resideo app. I’d like to be able to link these thermostats as well, again for the purpose of querying for a dashboard. It’s not clear to me if I can use these thermostats with the Resideo app and link them, or if I need to connect the T6s to the TCC app, or ???


My answer is partly a guess. However, I have used both the Resideo app and the TCC app to adjust my thermostats manually using my phone. Although the TCC app has supposedly been retired, it was (and maybe still is) available on the Play Store for download (along with the Resideo app) (I have an Android phone). In a sense, though, it’s irrelevant which app you use to control the thermostats manually. When you want to link them to SmartThings, after installing them and connecting to them to the Resideo app on your phone, you then add a Device in SmartThings and search for Partner Devices. Scroll down the list and you’ll see two Honeywell options: Honeywell Home and Honeywell Home Total Connect Comfort. The only “link” that works for me is to select the Honeywell Home TCC option. I have tried connecting Honeywell Home to my SmartThings app and it can never find my thermostats. However, your devices are newer, so maybe Honeywell Home will work. I have been advised, maybe in older messages in this thread, that only the Honeywell Home TCC link/device works. If things don’t work, you can delete the links and start over (as mentioned above when I first started this chain). Good luck.

1 Like

I have a Honeywell T5 WiFi thermostat and use the Honeywell Home (Resideo) App and it links just fine with SmartThings.

The only problem is that the room temperature only updates a few times a day in ST. So I run a refresh Rule every 5 min. in SharpTools to keep it updated.


Thanks. It’s the same with TCC. I have a SharpTools rule running to refresh it as well.

I also run a refresh rule in SharpTools so I can check to see if someone turned the AC on too high so SharpTools can cut it back down. :stuck_out_tongue_winking_eye:

1 Like

My recollection is that the Resideo app was called “Honeywell Home” to begin with.

As others have mentioned, there is a Honeywell Home cloud service you can link which I believe will let you control the newer thermostats.

I’m linked the other direction from what you’re asking. Thermostats connected to TCC. Honey Home/Resideo service also linked to TCC so I can use the cleaner interface provided by the Resideo app. If I add the Honeywell Home service to SmartThings it does not show the TCC thermostats. At least it didn’t the last time I tried.

Will echo others about the refresh problem and the need to use something other than the SmartThings app to refresh on a reasonable frequency.

Well here’s a first. I can control my Honeywell TCC thermostat via SmartThings right now but not via either of the Honeywell apps.

Both the Resideo app and TCC app have been failing off and on for maybe 10 days. TCC gives an authentication error, Resideo gets into a weird error page.

Cold front blew in today so our temps went from mid 70s to mid 40s in about an hour and will go to about freezing overnight. So it was time to switch over to heat mode.

I’ve got a manual routine in SmartThings to do all three thermostats. I ran it and then opened Resideo to double check. Resideo wouldn’t open and neither would TCC. But when I walked around to look at all the stats, they had all changed to heat.