HomeSeer HSM200 Support

@erocm1231 @abavery That worked!

Based on this experience, a UI tweak I would suggest is to rename the “Configure” button to something like “Push Settings Change” or “Push Config” to make it explicit to the user that any changes to Settings must be pushed.

Eric, overall the code that you have helped develop is awesome! Thank you so much.

Configure is actually the common verbiage for that function in the SmartThings platform. I did just push a change though that makes the handler automatically execute configure after you change the preferences and hit done.

1 Like

“Configure” is part of the Z wave standard. Both this device and the SmartThings hub are certified Z wave devices. So the term “configure” has a specific meaning in this context.

Here’s the official conformance statement for this device from the Z wave alliance website. :sunglasses:

Wow ok, that’s even better. Problem solved then!

2 Likes

Is there a way to set color based on mode change? I’m thinking about buying this to use as an indicator for when SHM is armed.

Need help to see temperature in Smarthings app.
All I am missing something simple, I bought the Express Controls EZMultiPli (same thing as the HSM200) and attached it to an electrical outlet outside my house. All I want to be able to do is get the temperature reading on my Smartthings app.
I have a Smartthings version 2 hub.
Here is what I did so far

  1. After plugging in the sensor to the outlet it was flashing green and I tried to add the sensor to my hub via the iPhone app. I was not successful in doing this.
  2. I read this forum and logged into https://graph.api.smartthings.com
  3. I went to My Devices and clicked on “+New Device”
  4. I put this info in on the following fields
    Name Temperature Outside HSM200
    Label I left this blank
    Zigbee ID I left this blank

Type I selected HomeSeer Multisensor
Device Network Id I I copied and pasted the following URL


Version I kept as "Published"
Location - I put in my hub name from drop down "Home Stroud"
Hub - Location - I put in my hub name from drop down "Home Stroud"
Group I left blank

After doing this the temperature sensor shows up in my smartthings iPhone app under “things” but it only shows “motion” I can’t figure out how to have this show me the outside temperature.

I tried fiddling around with the config of the “thing” in the iPhone app and saw nothing to change.
I tried changing the “Type” in the https://graph.api.smartthings.com to “Temperature Sensor”, that did not work.

I even tried using https://github.com/mjmac/smartthings/blob/master/hsm200/driver.groovy as the device network ID.

Can anyone help me configure this so I can see the temperature? Thanks in advance and sorry if this is a dumb question. James

After reading various things here and on Amazon.com reviews here is how I finally configured this to work with SmartThings hub (version 2 in my case)
Instructions to get EZMultiPli is also known as the HSM200 working with SmartThings Hub version 2

  1. Plug the EZMultiPli is also known as the HSM200 into an outlet. When you do this it should flash green.
  2. On the side of the EZMultiPli (or HSM200) you will see a very small button that is about 1/8 of inch long and a few millimeters thick. Press and hold this for about 30 seconds, it will start flashing colors (I think red) and then it will stop flashing, at this point open your SmartThings app on your iPhone or Android device and click the “Add A Thing” under My Home
  3. You will then see a new thing called “RGBW Light” added to your SmartThings. At this point it is not configured yet.
  4. Go the https://graph.api.smartthings.com and log in
  5. Go to My Device Handlers at the top and click button “Create New Device Handler”
  6. Under “Create New Device Handler” Click on the “From Code” link at the top
  7. Go this this URL https://github.com/drzwave/ExpressControls/blob/master/EZMultiPliDeviceType.gy and copy the code into your clipboard or memory of your PC or Mac
  8. Then Paste the code into the blank white box under the Create New Device Handler in the From Code link
  9. Click the Create button at the bottom
  10. From https://graph.api.smartthings.com/ go to My devices and you should see the RGBW Light Device, click Edit
  11. Click the Type* field and scroll to the very very bottom and you should now see “EZmultiPli” select that
  12. Optionally select Label to something more useful as in “Temperature Outside” (you can do this from the SmartThings app on your phone)
  13. Click Update
  14. Now in the SmartThings app on your phone you will see the temperature, you will have to enter the “thing” and leave it and it will soon show up with the temperature
1 Like

Glad you got it figured out. The method you mention in 1 & 2 is the Z-Wave inclusion process. It will generally work the same with every Z-Wave device you get. You put your SmartThings hub in inclusion mode and then press a button on the device. Some devices will work with SmartThings at that point & some need custom device handlers installed.

I followed the procedure that James created (Thanks James), and I gave the device added. It’s not working as I think it should though. The sensor has a steady flashing blue LED. Has for hours. On the phone, the configure button does not work, the light on-off says it’s turning on or off, but has no effect on the blue flashing light. The temp reads – as does the lux. On smarttiles, the temp and lux say n/a and the motion says motion. I have unplugged and replugged, removed and re-added the device. No change. I wonder if the sensor is bad? Or, if I missed a step…

Do you know if others have had problems similar to what I am seeing? Unresponsive sensor, and steady blue flashing LED? I am starting to think the sensor is simply bad, but I am not sure of that.

Okay, I have an update. I got it partially working. I used the code from the above posts with the last update 2016-10-06.
It shows temp, motion, and Lux. The one quirk is that the config button does nothing. Any ideas?

The configure button generally just sends configuration commands to the device. When you say it isn’t doing anything, what are you expecting it to do?

1 Like

I noticed that when you execute to turn on the LED, it always goes to the default color, but you can overide the color gamut but when you turn off the light and back on, it goes back to the default color. How do you set this to always use a color that you set manually or can set in the DH to a different default.

please advise.

I can’t get mine to pair follow the steps discussed in the previous replies by strouja. Going to contact the company on Wednesday. Hopefully they have some answers.

Is anyone still supporting this device for Smartthings? I just purchased one, installed on my network and updated to the latest device handler, yet I can’t get the motion sensor to work (it works fine when you first plug it in and it’s in “test mode”), and I also can’t get smart lighting automation to send proper SetColor commands (at best it will send a command to setcolor to #ffffff and then immediately send a command to setcolor to #000000 so it only quickly blinks white, regardless of what color I’m trying to send). I exchanged for a new one and it has the exact same behavior so I know it’s not the hardware…

Hello @DuhDude,

I just installed one of these a few minutes ago. Can’t comment on the Smart Lighting Automation because I haven’t played with it yet. That said, motion wasn’t working for me when, after it paired as a RGBW light as expected, I switched it to the default EZMultiply DTH as provided by SmartThings in the dropdown.

I created my own local DTH using the most recent link I found in this discussion (https://github.com/drzwave/ExpressControls/blob/master/EZMultiPliDeviceType.gy) - switched - and, like a miracle, motion started working, which is something.

Good luck!

[Edit - @duhdude although motion is working fine - I’m having the same experience as you with not being able to set color in Smart Lighting automation (or the regular automation in the new app). As in your case, all I’m getting is a setcolor to #ffffff and then immediately setcolor to #000000. Also, although I can manually control on/off and color in the Classic app, if I try to set color in the new app it hangs up. I’m going to see if I can do anything with WebCore - and if not, this might be a return, which would be a pity - I really like the concept]

1 Like

@DuhDude I finally decided to return it. I was getting some functionality with it using WebCore but in general I wasn’t happy with it. Some of the colors (white and purple in particular) were really unattractive (white was a pale sickly orange, purple an unpleasant pink). Given the limitations and appearance it just wasn’t worth the spend for me. (The colored indicator light was my main reason for getting it).

For the same price I created a very elegant and superior solution by combining

  • A HS-FLS100+ hardwired motion sensor (that screws into a 1/2" electrical box hole)
  • A White, 3-hold Round Lamp Holder Electrical Box Cover
  • A plug-in, hanging Lamp cord cable (with screw-hooks), and
  • A Sengled Z-Wave Multicolored Bulb
  • 2 screw hooks, 2 wire nuts, and some electrical tape
    You mount the electrical box cover wherever you want the motion sensor to be (the cover alone has just enough space in it that you probably don’t need an actual electrical box behind it), and then you splice the lamp cord cable to run power from the wall outlet into the electrical box cover, and then run the other side of the lamp cord cable out of the electrical box to wherever you want the lamp to be (discarding any excess cable length). You’ll end up with a much brighter beacon bulb. SmartLighting sends TurnOn, SetColor, and SetDimLevel commands in response to a single trigger. This is some quality looking hardware vs. the HSM200 and what’s more, you don’t have the color bulb attached to the motion sensor if you don’t want to.
1 Like

I would love to see a picture of this!

Here’s the setup! Not what I’d call beautiful since the wiring is exposed but good enough for the garage. Plus the materials don’t have the dollar-store plastic look that the HSM200 has. The part of the cable you can’t see just plugs into the wall. The red wire on the motion sensor in this case doesn’t attach to anything (i.e. the light bulb is always fully powered just like a smart bulb ought to be) but that red wire is just a simple smart switch so you could have it power something too. You also have the option of having the motion sensor operate that relay independently of a smart home hub, just like a regular “dumb” floodlight motion sensor. I go in and out of my garage all the time and I was tired of battery-operated z-wave sensors always turning off the lights on me because they are not sensitive enough and get tired of always reporting your motion status to save their batteries I guess. This solves that problem 100%. The smart switch it operates is inside the house, otherwise the GE 26933 switch is equally good. The bulb indicates the house alarm status where red=armed, green=disarmed, orange= “I’ll arm the alarm next time I sense that the garage door closes”, blue="there’s someone approaching the garage window so I need to turn off the garage lights right now so that your mirror tint works properly

"

2 Likes