History Missing

It wasn’t expected behavior in the Classic app. Sadly, it now appears expected behavior in the new app, because the history seems to have to go through more cloud processing before it will show up. Even when all appears working the history of opening/closing a contact sensor can take seconds to be reflected.

@Alwas ,

I see this in my history, but the history events appears after click in filter, uncheck and check in one type, for example, other and click done. All History events appears.
The refresh procedure does not work well in app, but this I’ve seen happening for a long time


1 Like

Yes @Mariano_Colmenarejo , it appears if I uncheck the first option, “Other” (whatever that is), the history appears to populate correctly.

But if I further uncheck a device, like my oven smart plug, because I don’t need to see the power changes, I get a sign saying “No activity” and an otherwise empty screen!

1 Like

@Alwas ,
I think clear that it is a problem with the filtering and refreshing procedure of the app.
If you see history when all the devices are marked, they are on the server.

In my case, once all the events are shown, if I filter by devices it works fine, but I will look at it more closely.
I use Android version.

1 Like

Is anyone else having issues with history (Iphone app) not refreshing? Mine says no activities, even after I toggle filtering as mentioned prior. My automations are functioning properly so history should be updating. If i need to debug, it would be impossible not being able to view history activity.

I use android and history working, but need refresh with some filter to see complete.
There is other post for iOS history:

Contact SmartThings support.

I already did, here is their reply.

Hi there,

Thank you for writing back to us.

I am really sorry for the inconvenience caused.

As of now, there is a known issue with the history of iOS devices. Right now there is a known issue with seeing the history within the iOS version of the Smartthings application. Right now we are working to fix the issue and we do not have a estimate for when it will be fixed.

I truly understand the situation. Meantime we highly appreciate your patience.

Regards,

Samsung SmartThings Support
www.smartthings.com

It was working last Friday for the first time in a while then just stopped again. iOS

@James_H any update on a fix to the history issue? Thank you.

No update from Samsung, my history is still not refreshing.

History is now updated and is refreshing, check yours.

1 Like

You forgot to include “at the moment”. (unfortunately)

Device event history has not been updated for 12 hours in app and IDE.
only automations are seen in history.
Does this happen to anyone else?
Europe, Spain

It looks like my device history stopped just before 2pm local time (currently 10:15pm in UK) , except for a single report from a custom virtual device that reported 45 minutes ago.

Automations and rules etc seem OK.

Mine at 10 am.
I mentioned it to support-uk at around 1pm in an e-mail on a different topic, but did not receive a reply.

Thanks for reply

Resolved.

https://status.smartthings.com/

I’m on iOS but mine will come back after a few close-open cycles of the app. Just one of the sad new bugs with the newer app update for me.

The event history stopped again today from 4 hours ago, at 6:30 a.m. (utc + 2)
Since July 1, almost every day the history has periods of inactivity and part of the logs are lost in the simple event logger app

History delayed by 24hrs on my virtual devices atm. Galaxy S9 Android 10