Help with port forwarding

hubv2

(Scott Mac Leod) #1

My old v1 hub died, so I bought a v2, thinking it would be a 1 for 1 swap. Boy was I wrong. Plugged it in, continuous blue light. Tried calling ST support about it. Got told it must be port forwarding issues. OK, then how about walking me through doing that? Sorry, we don’t know how - which is partially understandable, given the incredible number of routers out there. Now what?

So I have a Netgear cable modem/router/wireless. When I get to the page to forward the five (443 is open already), I am at a loss. Go to the page of the router set-up, and I am clueless. Screen shot of the page is attached. ST told me it needs to be UDP - but what do I put in the other fields? Do I need a starting and ending port of 11111, then one for 9443, then 39500, etc? Or do I just open the entire range (doubt it, but thought I needed to ask). So for 11111, what goes in “starting” and what goes in “ending”? And that is internal – what about external? How about internal IP address? The router IP address? Static or dynamic? Then finally, for external IP address - “any” or “single address”? If so, what? The IP address of my device 72.182.24.xxx? Or something else?

Sorry to be so dense. I am decently tech savvy, but this is out of my comfort zone. Thanks if any of you can help.

Scott


(Ron) #2

If you have UPnP enabled port forwarding will configure itself.

I don’t port forward and I have both V1 and V2 hubs installed.

If you don’t want to use UPnP for some reason then the ports you need to forward are listed here.

There are listed on this page
"Double-check your network settings and make sure the following ports are open during initial setup: 11111, 9443, 443, 39500, 37, and the NTP port (123)"


#3

I agree with Ron.

Port forwarding should not be required. Like him I also would not know which ports to tell you to forward. I’m sure others will chime in here and give you some additional helpful information.

I think support is off the mark here and something else is going on.


(Ron) #4

HeHe I updated my post with the ports after a quick search. So Phil was replying to my original post which said I don’t know the ports but it must be listed somewhere :slight_smile:


#5

Yeah, I saw that Ron. Good job on finding those port numbers.

Still say though this isn’t a port forwarding problem. There may be something in the security settings of the router that may need tweaking that’s blocking one of those ports however.


(Ron) #6

If he has UPnP set to OFF then it very well could be the port forwarding issue but you are correct if UPnP is on then he could have another device in the home which has port forwarding on the ports already preventing them from working on the Hub. It seems the ports are only a part of setup, not sure why. I had two hubs V1 and V2 installed for a while and they both worked so they couldn’t have had the same ports. Unless they only request UPnP on demand and then release then it could work with other devices which do the same. Hard to say without more detail and a view of more of the router settings.


#7

Typically routers are just isolating the private network so it can’t be seen from outside the LAN. So unless there is a setting somewhere specifically blocking certain ports all the traffic coming in from the outside should be passed along and directed by the router to the originating device.

I’ve not run into this before with any routers I have ever had at my house. The only time I’ve ever used port forwarding was to allow my ip cameras to be reached directly from outside.

I’m kinda babbling I know. Trying to think this through. It’s not making sense so far.


(Brian) #8

Turn on Upnp. Then reboot everything.


(Scott Mac Leod) #9

UPnP is on, per the attached screen shot. Port 443 is open, thanks to some device named “NP-13C2AD090540”

Any other suggestions?

Thanks for all the help so far. Will get there eventually. Appreciate everything here – the Netgear community has been ZERO help.


(Scott Mac Leod) #10

UPnp is already on.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #11

###SmartThings does not require port forwarding nor UPnP!!!


(Ron) #12

OK, did you try configuring port forwarding for the ports listed in my post above ?
I see port 443 is already going to 192.168.0.13 as is 80. These ports are http and https. Is 192.168.0.13 your hub ? If yes they you are OK, if no then this is a conflict. What is that device and do you need it configured this way. If you have a computer running a webserver it would need these ports for example.

Also here are some more suggestions that could help.

  1. make sure cable is connected correctly, My hub was down just last week because the cable came lose due to a broken lock tab.
  2. Try switching the cable with one you know is working or test the Hub cable with a notebook computer or other device.
  3. How is your security configured, do you have any firewall features enabled ? I am not familiar with that router.
  4. has the hub ever worked. Consider it might be faulty. Exchange for new one if you can.
  5. do you have any other routers you could test with ?
  6. Are you double nated ? This happens when you connect a router which has dhcp configured and your modem (cable, fios, dsl, etc) is already configured for dhcp. This can cause problems because your router is configured for UpNP and/or port forwarding but the modem isn’t.
  7. perhaps connect your hub to a friends router and see if it works.

Just some ways I would debug this issue.


(Ron) #13

Then why is it listed on this page ?

How would it receive server events if it wasn’t reachable ?
It would have to poll their server very often and that means everyone’s hub would be polling the servers on a continuous basis…wait maybe it does do this given the issue they have with load…hmm.

It’s sad that this isn’t clear and that they don’t just document how it works.
@tgauchat do you know how it works ?


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #14

Double checking that article, but assuming the SmartThings Hub opens an https connection to the SmartThings Cloud and tunnels all activity to and from that.

This is a very typical configuration for Internet exposed LAN devices to save the consumer from requiring advanced and/or risky Router configuration.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #15

Double-check your network settings and make sure the following ports are open during initial setup: 11111, 9443, 443, 39500, 37, and the NTP port (123)

This means you must not have these ports blocked by a router firewall.

Port forwarding is only required when a LAN device doesn’t initiate the connections (which the Hub does). For example, if you run a web server or simple IP cameras you try to connect to them from the Internet, then you need NAT (network address translation) baed port forwarding to translate your incoming connection request to the internal device’s address.

Nest / Dropcam / Hue Bridge / … / SmartThings avoids port forwarding by initiating the connections from inside your LAN. But firewalls can be configured to block this on a port by port or IP by IP (or even application or packet type) basis.


(Scott Mac Leod) #16

Ron – 192.168.0.13 is my NAS. Tried the new cable trick, nothing changed. Router and modem are in the same box, so that double NATing thing isn’t the issue

Finally got totally perplexed by the fact that the device never showed up in the router’s attached devices table. Also, no network activity lights on the RJ45 port on the back (or on the one it was plugged in to on the switch). So, called ST tech support and they agreed to send me a new hub. To answer your question, it never worked. Was a replacement for a v1 that died, and it never connected to anything.

Thanks for all y’alls help. Will nave to see wha the new hub brings.


(Ron) #17

@Scott53 That has to be frustrating. I hope the new hub works better. Given that you are replacing a V1 Hub which was working connected to the same router I would really expect the v2 hub to just work when plugged in. Good luck.


(Scott Mac Leod) #18

Well, finally got it working. Went to open all the ports, and couldn’t because the device was never seen on the connected devices table. So, last step was to try connecting the hub directly to one of the two ports coming out of my cable modem/router. Was reluctant to try that, because the VoIP box we use demands to be #1, and the other went to the daisy chained powered switches that feed the Cat 5 cable runs through the house. But I was down to the end. So, did it and checked the phone for any degradation, and there doesn’t appear to be any.

So far so good – now I have the pleasure of disabling every device and reconnecting them. Can’t believe how hard Samsung made it for those of us that are upgrading from v1 to v2. Shouldn’t have been this hard – feel like they put zero effort into automating that process. Oh, well - at least it’s working. Thanks all for the suggestions and support. Very much appreciated.


(Mark) #19

Thank SmartThings, the startup company that became a part of Samsung, for that one.

On second thought, many people on this forum have said it felt like ST rushed hub v2 to market when they were bought by Samsung in order to please their new corporate overlords. So maybe it was samsung’s fault.