Help, smart app doesn't work with HUAWEI cellphone


#21

tried your method, didn’t work, Thank you


(tao) #22

iam using mate10pro, 2.2.7version method worked for me


(John) #23

I have this exact same issue with my Huawei P10 lite yet the app works on an Elephone p7000 and a Sony Z1 compact. Support just told me it was a know issue and that thier engineers are working on it (this was before Christmas)


(Rod Stevens) #24

I dont know if this will help your issue, but this process helped mine:


(Robert Bozman) #25

Is there a solution to this problem? I don’t see anything posted since Nov 2017. I just got a Huawei Mate SE on July 16, 2018 and it’s having the same problem.


(Liam) #26

Sorry to revive an old thread, I’m still suffering this issue with the latest flagship phone from Huawei (P20 Pro). Still can’t get either app to work, does anyone have any solutions?


(Brian Steere) #27

If I had to guess, your phone isn’t using Chrome for the webview. Changing that is a bit of a pain, but it may fix your issue.

You can choose your WebView provider by enabling Developer Options and selecting WebView implementation . You can use any compatible Chrome version (Dev, Beta or Stable) that is installed on your device or the standalone Webview APK to act as the WebView implementation.

If you don’t already have developer mode enabled:

To turn on developer options , follow these steps:

  1. Open your app drawer and tap Settings to open the Settings app.
  2. Scroll down and tap About Phone. Look for the setting “Build number.”
  3. Tap “Build number” seven times in a row.
  4. A toast notification should appear saying you’re now a developer . That’s it! You’re in.

(Jon Clayton) #28

I found a fix on my Honor 10.

Load up chrome browser. Login to account.samsung.com

Then fire up smarthings app and login and it seems to work now.


#29

Still does not work.
It’s been 12 months and they can’t get their !@#$! website working with a web browser?

WTF?!


(Ron) #30

Kudos to you!!! This worked for me. I was banging my head against a wall forever. Finally gave up and kept my old motorola phone in my desk drawer for months and pulled it out if I ever needed to run the SmartThings app. What a pain. I finally took another run up the mountain and found this post that worked for me. Very disappointing this has been a problem causing hours and hours of frustration to many people for such a long time. Further, there should be a Windows 10 app for the hub that would also be a great workaround. Makes me NOT want to purchase Samsung products in the future where possible. The SmartThings hub is too good to not use for my situation and I am not going to be a victim, but in general when given an option I will avoid Samsung products.


(Alvaro) #31

Still no solution.
WHAT IS GOING ON?
Huawei Mate 8 here and NO way to make work Smartthings app, when I click “log in” it kinda freezes in a infinite loop loading screen saying “in course”
Is smartthings going to solve this someday?
Just bought all new things, even a new TV, thinking about connecting everything and now I cant because having a Huawei. In other phones work but I cannot borrow someones elses phone just for this.
Solution now!


(Dino Ciuffetti) #32

Does not work with Huawei P20 pro… what a shame! Samsung software is ALWAYS really behind its hardware…


(Dino Ciuffetti) #33

I just solved my issue with the smartthings app on my Huawei P20 Pro! I had to select “Chrome” when the app asked me how to open the browser. The key was to select “ALWAYS”. After that the login prompt appeared and that worked.

Found that hint here (step n. 4):

Thanks