Help Please Can't find the ZWave exclusion option in New App

I have researched the topic and it says that if you click on the hub under devices and then the three dots it should be here. I don’t have that option. I am using the Samsung Connect Home Hub and Wifi mesh system. I would assume it would all be the same? I was able to exclude devices in the old app with this system. Please see the attached pics as it may explain more of what I am looking at.

An alternative option is to use the z-wave tools tHat are available in IDE.

I am not sure about the connect hub but I know the z-wave utilities are not available for those with v1 hubs. It could be available for hubs witH a particular firmware version.

Weird cause it is not the version 1, it is the Connect home model which is fairly new.

It should be there, try sending the screenshot to and see what they say.

Meanwhile as @jkp said you can use the exclusion option from the IDE under My Hubs

Thanks RBoy. I will contact support and appreciate you and @jkp 's advice to use the IDE. I never thought of that. To get around the issue I had yesterday I was able to download the classic app again and use the exclusion there. Just snuck that in at the 11th hour as I think it got shut down yesterday.