Help Needed - Neo Coolcam Powerplug 16A (NAS-WR01B) not showing power monitoring

I recently bought some Neo Coolcam Powerplug ZigBee 16A (NAS-WR01B ) because they where the only plugs I could find in my area that would support 16A and had power monitoring, they where labeled as “Works with Smartthings” but that was a half truth.

I can connect them and control them but there is no way to see power monitoring so the question is if anyone know of any device handler that could fix that problem(or have any other solution) or if I just have to give up and take them back?

Could you provide the meter, manufacturer from the IDE and what controller are you using?

It would also be useful to know the clusters it uses, to know if it supports power and energy information.

I’ll be honest there is a lot in that question that I do not fully understand so I’ll post the info that I have and I truly hope it’s what you where asking for. If I missed something please do tell, and also where I find it.

I’m using the “Aeotec Smartthings Hub” (IM6001-V3P22)

The device:
Neo Coolcam Powerplug ZigBee 16A (NAS-WR01B)

From the manual:

Communication Protocol: Zigbee 3.0
Network Protocol: Zigbee IEEE 802.15.14

From the device:

  • application: 4A
  • endpointId: 01
  • firmwareFullVersion: 0000004A
  • firmwareImageType: 54179
  • firmwareManufacturerCode: 4417
  • manufacturer: _TZ3000_gjnozsaz
  • model: TS011F
  • zigbeeNodeType: ROUTER

Sorry, sometimes we talk about terms that not everyone has to know

This device is in the Edge driver Zigbee Switch Power Mc

  - id: "_TZ3000_gjnozsaz/TS011F"
    deviceLabel: TS011F Plug
    manufacturer: _TZ3000_gjnozsaz
    model: TS011F
    deviceProfileName: switch-power-energy-plug

This driver is on this shared channel

If you have not used Edge drivers, you have to do the following:

  • Open the shared channel link
  • Accept the terms of use and enroll your hub in this channel
  • Find the driver you need, Zigbee Switch Power Mc, click in install it on your Hub
  • In the app uninstall the device
  • Put the device in pairing mode.
  • In the App add a new device and press search nearby
  • In a few seconds, up to 1 minute, it should find the new device, it will be in the unassigned room.

If you have any more problems tell me

1 Like

Thank you so much! That just worked!
I’m in stupid awe and do not have the words to convey how much that help meant to me.

Truly, thank you! You’re a star!

1 Like

I’m so glad it worked for you

1 Like