HELP! Alarm won't disable

SmartThings support hasn’t been very helpful lately, not reply for weeks to my tickets.

I’m an original Kickstarter backer, and SmartThings worked great for a good year. But after many updates to the app it’s just started breaking, alot of buggy functionality and i’ve had to completely reset up the app and system more than once.

Anyways, I want to disable my Alarm at 6am. Simple routine setup. I deleted and setup multiple times, still not working.

Here’s my setup. Am I doing anything wrong?

open up the IDE and check the logs?

What’s that and how do I view?

Can you try something for me? I’ve been looking for a new test case to see if my theory is correct.

Can you add a light to the routine and tell me if the alarm will then disarm/arm as you would expect?

I added a light to turn off and a second attempt for a light to turn on. Neither solved the problem and the alarm will not disable.

Any other ideas?

Make sure no dimming setting is running. Just heard that’s a bug they’re working on.

I removed all sonos connections and it it cleared the issue.


So to make sure I understand, when you added another device to the routine it worked?

No, I removed all Sonos smart apps.

I had a bunch in the setup, like turn on when alarm triggers, etc.

Removing them all and testing the disarm again resolved the issue.

My setup is simply.
2 X Door Sensors
1 X Leak Detector
1 X Siren

I was playing around with Sonos and never really got it working properly which was the cause of this issue.

Interesting, thanks for the info!