Hello Home Action not firing (not sunset issue)


#1

I don’t know if this is related to the reported scheduler issues or not, but it’s making SmartThings completely unusable for any scheduled actions for me. :tired_face:

My Good Morning Hello Home Action does exactly one thing: change the mode to Home at 8:00 a.m.

For several days it hasn’t fired, leaving the house in Asleep mode.

I set up this HHA the day I got ST and haven’t changed it since, so…

I’ve reported it to support, along with some other recent failures, but it would be hard to define a purer cloud issue than this.

Very depressing, to be honest.


Device preference options of type bool, number and enum not being displayed in App
(Ron S) #2

@JDRoberts Checking in the IDE if my hello homes triggered. At least the “GoodBye!” did trigger as it appears as the home is in “Away mode”.

Something weird is going on. All of a sudden presence status from Home and Family disappeared, appeared and disappeared. The hello home page is empty. Door status is incorrect.

It is happening every minute or so. Appearing and disappearing. And also got an error message once. “An error has occurred”.

@april @tyler is some platform update going on?


(Alex) #3

My ST Mobile app crashes when I open Hello, Home page.

Android 5.1.1 with SmartThings 1.7.4.


(Ron S) #4

Force closing and opening the app on iOS is throwing the error…
Steps to reproduce the error:

  1. Force close and reopen the app.
  2. Click home and family to drill down. Error is thrown as shown In the post with images.

(Bill) #5

I’m seeing similar things with mode changes that have worked for 6 months. I have one that fires at 8:00 and another that fires off at 9:30 if I’m still Home (working from home). It shows me present, but never fires off now.


#6

@April : The Status page has been updated to say there may be android issues, but Ron and I are on iOS, so it’s not just that.

Investigating - Android users may be experiencing issues accessing their dashboard. We’re investigating the issue and will update here accordingly.


(Ron S) #7

@April Please ask support to update the status as it is very much an iOS issue too. We are facing the same issue. I have opened a ticket and hope that IOS dev. team is aware of this.


(Ron S) #8

Checked with support and they are aware of iOS issues as well.


#9

So I wonder if this is related to good morning not firing or not.


(Ron S) #10

My good morning is based on “Things start happening” based on a Fibaro and ST motion sensor in the hallway during the period of 5:00 - 6:00 AM on week days. No issues this morning. “Good bye!” triggered fine… Once in office, I checked ST mobile app and then started noticing these issues. Hope “I am back” triggers and mode changes… Don’t want to get home with sirens blazing all over.


#11

So support tells me these are likely at least 3 separate issues that happen to be occurring at the same time. :scream:

  1. probably a server “hiccup” (their word) two days ago caused good morning not to fire. After that, it will never fire until I go back in and delete the time rule and re enter it.

  2. jawbone error is something different

  3. mobile app not displaying info is…something different.

Sadly, this exceeds my safety threshhold for reliability in home automation. I don’t expect things to be perfect, but as a quad, I need things to be more reliable than this.

My techie aide will be here tomorrow and we’ll move everything we can off ST. I’ll still use it as a zwave or zigbee bridge for awhile, via IFTTT, but all rules logics will be moved to something else.

This is a great community, but I just can’t rely on the system.


(John S) #12

I noticed presence was wonky and my Android app has been crashing this morning as well. Hope they get things squared away…


(Ron S) #13

Presence worked perfectly for me. No issues whatsoever.


(Ron S) #14

What bothers me the most is is different behavior for different group of people on Android or iOS. For me no issues whatsoever with hello homes, scheduled actions, presence etc. but dashboard is simply horrid most of the times.


(Ray) #15

Terrible timing for me. Trying to add a new phone, moving a couple of devices around and I thought it was me causing the errors. Been scratching my head all morning until the status email.


#16

Yes, that’s really the meta issue I’m facing. Lots of small issues failing unpredictably. Get ready to go to sleep, Jawbone fails to turn off lights. Get up in the morning, Hello Home fails to fire. Try to start diagnosing issues, dashboard is blank. Decide to go out for awhile instead, motion sensor fails to trigger mode change.

I have neither the time nor the energy to keep checking everything to see if it actually fired or not. Or to keep reinstalling if something does “hiccup.”

As a hobby platform, SmartThings is great fun for people who like to code.

But as an environmental control system for a quad, all these “little” things just add up too much unreliability.

We can’t blame mesh for the mode not being set, or for no notification being given that some kind of reset may be necessary. Those are cloudside design decisions.

So it goes. There’s no great alternative under $15,000 now, so I will just wait to see what arrives at market over the next year. Meanwhile the Echo is excellent for controlling lights, and I will pare the ST use back to use cases where failures are obvious and alternatives are available.


(Ron S) #17

JD: I have made too many unnecessary purchases since September I joined. Nowadays more and more I buy products which are decent and have their own stock apps. Ecobee3, Rachio Iro, Dropcam, Philips hue and family, jawbone (horrid… Better take care of your UP24 as 2,3 and 4’s will take you nowhere), Echo, Sonos, MyQ etc. So, Only mainstream consumer products. Of course ST stays for the other zigbee/zwave requiring a controller… I have stopped getting worked up these days… Bad for my heart and BP! Once I have some funds, the CT100’s for heating 2 zones will be gone too. Should have spent more dough on home improvement rather than home automation.


(Ron S) #18

As such iOS app has become totally unusable since last update as it has become so slow (a different thread exists and was informed by support it was because of memory leak). I have seen zero improvements with this. You have to kill the app and pray that it works. It has become more of a headache rather than a convenience.

This morning it failed to switch off even 4 hues batch (1 was missed). From within lights & switches/shortcuts. It failed to turn off two bulbs on a single table lamp. I think finally Alexa will save the day. Everyday I have to check using hue stock app whether lights were turned on or off after hello homes.so, what’s the point? No iOS app update to fix anything…
Scheduled events and hello homes fire on the dot but doesn’t do what it is intended to do. Is that an improvement?