Harmony Connect broken


(Dan) #1

I had a working Harmony Hub integration until recently. I’ve been trying to add support for a second Logitech Harmony hub to SmartThings. Harmony Connect did not discover the second hub, and from searching in the community, it looked like I needed to re setup the hubs.

I did the following:

  1. Removed authorization in the Harmony Connect smart app.
  2. Tried to log in again - I keep getting a web service error HTTP Status 500 - Validation failed, with a stack trace. This happens immediately when I “Click to enter Harmony Credentials”, before I even get the chance to type any info.
  3. Tried to remove the smart app to reinstall it. Got an error that device is still in use.
  4. Removed the device from my list of Things. Verified that device is gone in both the web IDE and the SmartThings app.
  5. Tried to remove the smart app again.
  6. Still getting the same error about device in use and still unable to authenticate.

So at this point I am stuck and the Harmony integration is broken. Any suggestions? (I’ve posted a similar question to support, but if the community can help, that will be appreciated.


(Robbie Erwin) #2

I too have had no luck with my Harmony Hubs. I posted a topic about this a couple of days ago. I can log into the Smarthings IDE when the app redirects you there, login, select which devices, but when it directs you back to the Harmony app it times out and give me an error when trying to retrieve the devices.


(Dan) #3

Surprisingly, I was able to get it going again the other way, with Harmony controlling SmartThings. I used the Harmony app to re-login to SmartThings and authorize devices.

I’m guessing Harmony Connect is broken, so I still can’t get SmartThings to control Harmony.


(Dan) #4

I managed to get my Harmony integration going again after support helped out. The reason I couldn’t remove the smart app, was that I had some virtual switches that was linked to Harmony activities, that I had completely forgotten about. When I deleted those, I was able to delete the Harmony Connect app. After re-installing, everything worked first time. I was able to detect both hubs and set up my integrations again.


(Juan Risso) #5

Logitech Harmony API doesn’t send information about a hub added after the authorization happened. For that reason, we added a link at the button of the connect app to logout which allows you to re authenticate which will authorize the new hub without losing any of your previous integration.


(Dan) #6

That was the first thing I tried, but I suspect my app was old. I was unable to log in again after logging out.


#7

Does that cause any activities that have been renamed in the Harmony app to be updated in SmartThings?


(Juan Risso) #8

No, this update doesn’t update activity names.


#9

Okay, thanks.