Hardware, driver or zigbee channel problem?

I have a several zigbee temp sensors from aeotec and nedis smartlife. Aeotec sensors and POPP zigbee radiator valves never goes offline in normal conditions but nedis sensors goes offline in daily basis. It doesn´t matter if I keep sensors right next to hub, they still go offline randomly. Though they always come back online from few minutes to few hours and I don´t have to pair them manually.
I´m using general zigbee temp sensor driver but I´ve also tried Marianos driver but same thing here. I´ve also tried to change the zigbee channel when I still had fewer sensors but I don´t think that it had any affect. Also 2,4GHz wi-fi channel has been set up so that it shouldn´t mess up with zigbee.
So is the problem that nedis sensors are just crap because other zigbee devices doesn´t have even a smallest problems?

Maybe, have you tried a Zigbee mesh repair? If not unplug your hub and remove the batteries if it is V2 and then wait 30 minutes and plug it back in. This will force a Zigbee mesh repair. See if this helps. It can take up to 24 hours for the repair to complete. I do this every time I add a new Zigbee device.

1 Like

Thanks for the answer, I will try that assuming that it works also with V3?
I´ve read from some thread that doing z-wave repair from the app might also fix some problems with zigbee but I´m a little bit skeptical about that?

It works with V3 as well, just no batteries to remove. Zwave repiar wont help with Zigbee.

1 Like

When they go ‘offline’, have you tried warming them up or cooling them down to encourage them to report in?

In SmartThings, a Zigbee device that is marked as ‘offline’ may be working perfectly correctly in itself, it is just that SmartThings expects to see certain activity from the device and if it doesn’t see it then it expects to be able to give it a nudge and get an answer. However SmartThings’ expectations aren’t always a good fit for the device, and neither are the nudges it gives any help. So SmartThings may mark the device ‘offline’ and the mobile app will have a hissy fit, and then a while later the device will have something to report and all will be well again.

The classic example I have is Ikea Motion Sensors since they’ve been on the stock Edge drivers. Leave them for an hour or two without anything to do and they are quite likely to be ‘offline’. Walk in front of them and they are instantly back ‘online’ and the motion event is received and processed normally.


Same with my Sonoff motion sensors. It’s annoying to see them offline in the app all the time but I’m able to mostly ignore it now and just focus on any devices that are actually offline…

1 Like

Definitely check the sleeping/offline scenarios mentioned by Graham and Mark.

How far away is your SmartThings hub from any strong 2.4 ghz radio signals like a wifi access point? Zigbee can be drowned out if close to a wifi router. do you have any mains powered zigbee devices that can help strengthen your mesh?


You shouldn’t have to do this every time you add a Zigbee device.

I never did this, even when I had 100 Zigbee devices on my v2 hub.

1 Like

You shouldn’t have to, but it shouldn’t hurt, and it might improve network efficiency if devices end up choosing new parents based on the new network options.

I know lots of field techs who will do this every time just because they find it easier than trying to make a case by case decision.

Of course if you have a situation where you know some of your devices are poor repeaters for other devices, then you definitely don’t want to do it or you could introduce more flaws in the mesh. This comes up more often on a platform like smartthings where we tend to mix together a bunch of devices from different brands. :thinking:

1 Like

2.4GHz signal is pretty strong all over the house (I have a 4 routers aimesh) because most of my bulbs and cameras use wi-fi. Hub is so center of house as it could be and unfortunately I don´t have any zigbee repeaters. I´ve been thinking about of buying another V3 hub which I could get -50% discount from local store, but I´m not sure if it´s needed because aeotec temp sensors works like a charm even if they are as far away from the hub as they can be.
Problem is probably sleeping mode as mentioned here, because if I gently tap pairing button in the sensor that´s offline it wakes and reports immediately. Is there any way to prevent this? In Marianos driver is a option for report interval which is set to 5min but it doesn´t seem to work? Bigger battery usage isn´t a problem.

This problem seems to be solved. I don´t know if I was too impatient trying Marianos driver for the first time, but this time I made all my smartlife sensors use that same driver and now they work as they should and I haven´t got even a single sensor going to sleep so far.
Didn´t reboot the router, pair the sensors or do anything else than change the driver and wait.

Driver can be found in here: