GOOGLE Home not working

I’m losing my mind and feel like I’m the only person who can’t get smartthings to work with Google home. I’ve connected my account, I see all the devices and switches, but damn thing doesn’t work. I tell google home to turn on a light and no matter what I say it always tells me the light or switch " is unavailable." I can control everything fine through smartthings app. I’M so annoyed. Any thoughts?

1 Like

Nickname all lights without the word light

Hi,
Yeah, that was first thing I did. No matter what I say to googl home to control smartthings devices, it says, “looks like (device) is not available right now.”. Arg

Its the same with me. It was working for me till yesterday but today its the same response. It’s extremely annoying.

Strange it’s working for me. Maybe the server that hits you is down or overloaded

Now I have had Alexa respond to hey google and google not. That was strange. And it not only lit up but answered what I asked it to do in smartthings. Sometimes it responds quick others it does not but it sure as hell does 3 times when the stupid commercial comes on for GH.

I have found that this happens when I revoke access to a device. It seems GH still knows about the device but can not access it. Are you sure that you granted access to the devices you’re trying to control through GH?

yeah. I added Smartthings in the GH app. within the app, I logged into SmartT, chose hub, then put check marks next to every device and hit ok. GH shows all of the devices, but still doesn’t work. Same responsive for every device “not available right now.” It does appear to not have access, but I don’t know what else to do. Odd that I don’t see others with the same issue.

Good news.
I read on the Google Home support pages that the smartthings update caused some problems and the unplug ST hub for 10 minutes and start all over. Tried it twice and it FINALLY all works. Thanks for those who offered feedback :slight_smile:

The Google Home instructions suggest using the word “light” in the name or else Google Home may not recognize that a switch or a dimmer is for a light (see troubleshooting section here: Control smart home devices using speakers and displays - Google Nest Help ). So are you saying that you use “light” in the SmartThings name so it gets recognized by Home as a light and then use the same (or different) name without “light” in the nickname? Or were you unaware of the need to use “light” in the name to have Google Home reliably recognize it? Having to use “light” in some places to get the switch recognized, and then not use it in other places - i.e., in the Nickname - to fix other problems, seems pretty awkward and confusing.

If you do it will treat it as a room. I have living room as a room and if I said living room light it would effect the entire loving room. I renamed it to living room main and works every time. I know what it says I’m telling you from real world experience.

Thanks for the suggestion. I’ll give it a try.

This has been my experience. I have a light called “downstairs landing” at the bottom of my stairs. If I tell GH “Turn off all the lights” it will turn them all off - except that one. Makes sense actually.

The other thing is if the room name is in the nickname, such as “living room overhead light” and the light is in the “living room” then this causes confusion as well. A command to “Turn Off Living Room overhead Light” results in all the lights in the living room going off.

1 Like

I’m having a similar issue. I have single smart switches in two bedrooms. I can control them individually via ST app, no issues. When I tell GH to turn on or off the lights, by name… nothing happens. Seems that it turns both lights on or off, but not individually. I have them named as, Bob’s Light and Sue’s Light.

Get rid or light in the nickname. Name it Bob’s overhead or main or something as with the other and it will work do it in the home app not st.

Tried your suggestion. Still didn’t work. Kept saying its not sure how to help.

Make sure it is authorized in gh

GH is authorized. For whatever reason GH isn’t recognizing the lights individually, no matter what I name them. I’ve named them as, Bob’s Main, Bob’s Light, Bob’s Room.

Kinda weird and frustrating at the same time.

I agree with joeworm so far… FWIW, here’s my experiences with the whole “light” dealio…

Disclaimer: All of my lights are imported into GH from my Hue account instead of ST, but I don’t think that matters with respect to this topic…

In Hue itself, my lights all have longer & more descriptive names, but I use the Nickname capability in GH to really shorten those up.

For instance, I have 4 ceiling fixtures in my house that each have 2-3 smart bulbs in them. In Hue, each bulb is named along the lines like “Back bedroom overhead 2”. But when I mapped all of those bulbs over to GH from Hue, I then used GH’s “Nickname” feature to nickname each one of those various fixture bulbs (9 total) as just “Ceiling”; however, each bulb is assigned to its appropriate room.

It may sound odd that I have 9 “Ceiling” entries in my GH device list, but when you tap any any device in the GH app, it expands more details, and that will show the full/original name of the bulb (from Hue or ST), so if I need to see that level of detail, it’s still right there in the GH app for me.

Anyway, my point is that I can now say “OK Google, turn on the ceiling lights in the back bedroom”, and it works like a champ. In this case, I have to specify the room as part of my command since I have “Ceiling” lights in other rooms too.

Drilling deeper…

Like joeworm, I’ve learned that you don’t need to include the word “light” or “lights” in the actual device nickname in GH - that seemed to cause errors more often than not, and since I stopped doing that, I haven’t had any problems.

That being said, in my experience, GH is quite finicky about saying “light” vs “lights” in the actual spoken command

For instance, I have tall floor lamp in my living room that has 2 bulbs in its main fixture (upward-diffusing), but it also has an attached downward-facing single-bulb reading lamp too… In Hue, the bulbs are named “Floor Lamp 1”, “Floor Lamp 2”, and “Reading Light”. But in GH, my nicknames for each are just “Floor”, “Floor”, “and Reading”. So I can say “OK Google, turn on the Reading light” and that works because it’s a single bulb. But for the floor lamp, I have to say “Turn on the floor lights” since it is 2 bulbs. If I say “Turn on the floor light”, I get an error.

Oddly enough, I can even just say “OK Google, turn on Reading” and that works, but I can’t say “OK Google, turn on Floor” (that gives error). So, I’ve concluded that the word “lights” must be included in the command if the fixture has multiple bulbs (or if it involves mult. fixtures, but that situation makes OK sense)

In all of those cases, I don’t need to tell GH what room the light is in because those nicknames aren’t used for anything in other rooms (unlike my earlier “Ceiling” example).

It’s definitely a learning process, that’s for sure!

Cheers, Chris

Thank you for the reply.

I just nicked named one of the light fixtures, to Bob. Went to give a command of “Hey Google, turn on Bob” Seems like that worked. I’m going to play around with naming items differently. I suppose as long as the work “light” or “lights” aren’t in the name it should be ok. I have a pretty thick accent as well, so I wonder if a long name has something to do with it :slight_smile: