SmartThings is unavailable to Google right now (7 Aug 2021)

I’ve searched through here and various sources and still have the problem with google assistant saying, “Sorry, it looks like SmartThings is unavailable right now.” I give the command to turn on lights, it says the above quotation, and then executs the command correctly.

I have performed a factory reset on all Nest Minis and the Nest Hub Smart display. I removed SmartThings from Google home, added everything back and told it to sync devices. I’ve done everything separate and all at once.

Any ideas?

1 Like

Hey there! @CGLTD, Thanks for providing the steps that you have already attempted. You mentioned removing ST from Google Home, but have you removed and added back Google Home from Linked Accounts in ST APP and then attempted to Re-Link Smart Things in the Google Home app, and perform a “Hey Google, Sync Devices” to sync devices across providers?

You can remove Google to Disconnect Google Home from SmartThings, and re-link to SmartThings using this troubleshooting article: Set up and use Google Assistant or Amazon Alexa with SmartThings

Does the symptom still occur after re-connecting via Linked accounts in SmartThings?

I hope this message finds you well!

^SamsungZell

Thanks for the suggestion. I tried it that way you suuggested and still says ST is unavailable. The lights and plugs still follow the commands.

1 Like

No other suggestions?

1 Like

Be warned this isn’t going to lead on to any insightful suggestion …

Does this happen with all SmartThings devices you control from Google? Does Google Home show the devices having changed state after giving the command? Is Google’s idea of what devices you have actually accurate? Just sounds like Google might be issuing the command and not be seeing one or more of the SmartThings devices actually change state so thinks the command didn’t get through.

Hello. thanks for the reply. Just fixed it.

To answer your question. This only happened with lights. The commands executed correctly as requested followed by smarthings isn’t available. Google home showed the lights’ correct status.

I ended up deleting the household and started as new. It works fine now:).

1 Like

How do you do that? Do you have to reconnect all devices 1 by 1?

Hmmm. That’s not what I hoped to hear! Did you do this in ST or in Google Home? I have multiple rooms so am hoping that this is not the only fix.

There is a brand new problem affecting services and sites across the Internet today, 7 December 2021, which is not related to the previous problem.

You should not have to delete or reset anything: it is slowly starting to come back on its own.

See the existing discussion thread

Integreations to Google and Alexa down right now? (7 Dec 21)

I was having a similar issue with my Samsung TV. My Google Home would not turn on/off my TV, when it was working fine just days ago. When I gave it a prompt it would just say multiple variations of ‘the Google assistant on my TV needs to be reconnected’ or that ‘SmartThings wasn’t available right now’. I tried a quick reset on the TV, signed out of and back into the Google assistant on the tv, tried to sync all the devices (which Google told me it couldn’t because SmartThings wasn’t working), and unplugged both the Google Home and TV for 2 minutes. I also uninstalled and reinstalled SmartThings and reconnected the devices and checked everything for updates. None of it worked. What finally got it to work for me was forcing a reconnection between my Google home app and SmartThings (which was the easiest of all options, and what I wish I tried first: https://www.howtogeek.com/687234/how-to-reconnect-smartthings-to-the-google-home-app/).

Hey there! @CS28, Awesome to hear that you were able to resolve your symptoms, Thank you for sharing the troubleshooting steps that you used with the community!

I hope this message finds you well!

^SamsungZell