Google Home fails to run Scenes

Hi, a few weeks ago I had the frustrating problem where all the SmartThings scenes appeared for the first time in Google Home, but outside of rooms inside Google home and therefore suddenly stopped working and could no longer be initiated via Google home. I discovered on the forum that the solution was to add the scenes to a room. The scenes then started working. Annoying but okay I figured it out.

about four days ago all SmartThings scenes stopped working suddenly once again in Google home. This time all the scenes have disappeared from Google home and no longer appear in or outside of rooms.

I am going to guess what happened is SmartThings realized the above problem and therefore removed the scenes from Google home. after all it doesn’t make sense to have a scene in a room. A scene is not a physical device. However this means the scenes can no longer be run. It has completely broken the integration.

when trying to activate a scene from Google home or from within the scenes control option of a Google home routine, Google gives an error such as cannot reach SmartThings or SmartThings is unavailable right now. This has been for 4 days. I am going to guess that smart things changed something 4 days ago.

I have tried reconnecting SmartThings from within Google Assistant settings but it gives the same error. Cannot reach SmartThings. Or connection error.

When I try to say sync my devices it says only the person who set up SmartThings can sync it. That person was me on the same account.

I REALLY do not want to unlink smart things because I have about 120 different integrations and routines configured meticulously right down to precise light bulb brightness and color temperatures for specific moods. My wife also has many routines. She’d probably divorce me if I unlinked and deleted them! (Not really but you get the point.)

@Lars it seems this is happening at the same time that smart things are changing the Google integration. Is there anything you can do to improve this and get my scenes working again with Google home?

Many thanks.

1 Like

Update. I have fixed the weirdness once again.

I finally got smart things to reconnect. However, crucially it still does not show the scenes in the Google home app within rooms. The bottom line is if is scene is not in a room, it will fail with an error in Google home. That is the problem, as I suspected above.

HOWEVER I noticed when reconnecting that the Google assistant work flow did ask me whether I wanted to to assign a room to each scene. once again this is not possible after you exit the reconnection workflow. I therefore reconnected once again, and during that process assigned a room to every scene. Google calls the scenes “devices”.

Once I had done that everything started working perfectly!

Summary: Scenes must be in rooms or they won’t work. But it’s impossible to add scenes to rooms unless you reconnect.

@Lars I hope this helps and that things will stop breaking in this manner. It has been a frustrating 4 days, and support were no help at all.

Thank you.

1 Like

Another update:

The actual “Scenes” control in Google Routines is broken. If I check a scene, it just says “aren’t available”. That’s the whole sentence it says when run.

To get a scene to work in a routine you have to add it as a command “Activate scene name”.

This whole feature is quite a mess. I really hope it improves.

I use virtual switches to run scenes. You can make a room called “Scenes” to put the virtual switches in.

1 Like

Hi sorry to hear about your issues. We have made no changes on SmartThings side for several weeks now. “When I try to say sync my devices it says only the person who set up SmartThings can sync it.” is an error from Google so perhaps something has been messed up on their side, however PM me your SmartTHings account and we can look at it together. I wasnt even aware that you can place scenes in a room.

1 Like

Did you post this in the correct thread? I’m not sure of the relevance.

I’m running into the same type of issue, except reconnecting SmartThings to Google Assistant didn’t repopulate the Scenes. I’m trying the route of creating a virtual switch, but this is a hack, obv. Is there something that needs to be modified in order to allow the Scenes to be recognized by Google?

Unfortunately @Lars hasn’t followed up with me although I gave him a lot of troubleshooting info.