Google Home error: "Sorry, I couldn't reach SmartThings"

Tonight Google Home suddenly can’t connect to SmartThings. When I ask it to do anythinyg it says:

Sorry, I couldn’t reach SmartThings."

Similar message w/the one Wemo switch I have. Smarthings is up and running and fully`controllable from the app.

Nothing has changed recently on my network or Smartthings setup - everything worked fine last night when I went to bed. I was gone pretty much all day today, and now nothing works.

Any suggestions? I didn’t find anything useful from Googling around.

1 Like

Same problem here for a few hours now

Have you tried: “hey google sync my devices”? I don’t expect that to solve it but please try.

Also if you PM me your SmartThings account I can take a look.

1 Like

Seems to be something with the new app and classic app running at the same time.

I completely removed the connections (there were 2 connections…one where I could control what was visible to Google via old app and one that I could not via new app). I also removed all other “home members.”

Then I connected smartthings through assistant and it automatically reconnected via new smartthings app.

It doesnt look like the ability to connect to smartthings via the classic app using the smartapp exists? The problem with this is that we now have no control over what we expose to Google assistant like we used to in classic. If you have ecobee connected to smartthings and also to Google assistant…now you are stuck with duplicates. There are also instances where you might not want to expose everything to assistant.

Why was this decision made that decreases functionality?

Also - what changed that made this happen today/tonight where the connection to the old app caused issues?


Same problem here. It started a few days ago, when Ghome couldn’t control my Q70R TV as it did before.
I always used the turn on and off function by using a voice command, but first I noticed that my good night routine wasn’t working anymore and Ghome was replying back with “sorry, it seems that Samsung tv is not available” or something similar.

What I did:

  1. Renamed the TV in Google home
  2. Unpaired and repaired smartthings
  3. Disconnected both the TV and Ghome from the plug for 15 minutes
  4. Checked HdmiCEC
  5. Reconnected both the TV and Ghome to the wifi
  6. Re synced the Google home
  7. If the TV is on, it can be turned off through Google home, but not back on, and I get the same error. Same thing happens when I try manually in the app with the same error.

None of the scenarios above worked.
The TV can be controlled through the smartthings app normally, but not through Google home.

Also, last night I got the same “sorry, I couldn’t reach smartthings” error.

Thanks for your message. Resyncing didn’t work it said “something went wrong when sinking smart things.”.

Now it’s saying: “Sorry it looks like smart things is unavailable now” when I ask you it turn on lights or do something.

I’ll send you the PM.

Short update as it seems to be working now.

Go to Google home, tap +, tap set up device, tap “have something already set up”, click on smartthings and relink your account.

Afterwards, wait 30 seconds, and tell Google “please sync my devices”

1 Like

If what you’re saying is the actual problem, it could be that the hub firmware update that was just released is what changed.

Looks like I got the new firmware update today. See below. That coincides with the Google Home SmartThings control being broken.

Most probably it was a syncing issue after the update between smartthings and Google home. I’ll monitor the behavior and I will reply in a few days.

Funny thing is, that after my hub updated a few days ago, and I already did the process above, but it didn’t work then.

Also, I’m a cloud technical engineer, but work with a different kind of products. I do believe that the synchronization between the two services was interrupted after the update, but that doesn’t explain why it didn’t work the first time I followed the process above. Anyway, glad it’s working now, but I’ll still monitor it a while.

I did above:

Things are working again, though all of my devices are dupilcated - I have them all assigned to rooms in GH, and also a duplicate set of them unassigned to rooms. I’d like to just delete the unassinged devices, that the right approach?

EDIT: My bad, appears I probably don’t have a bunch of duplicates, just a bunch of devices that aren’t assigned to rooms so they initially looked like duplicates. I haven’t gone into GH in a while to review devices so for all I can remember I’m not sure if I ever placed all those devices in a room. Going to spend a little time on this later today to sort this out.

I also fixed my GH issue w/the Wemo switch, which I found was added by both linking to Wemo account and to SmartThings. I removed the Wemo link (which wasn’t working correctly) and now can control it via the SmartThings link in GH, and don’t get two messages from GH every time I tell it to turn the switch on or off (“OK turning it off”, followed by “I can’t reach the switch”).

See Updates to Google integration for more info.

Updated info - I do have dupes. But it looks like just for a few Hue lights.

When I ask GH to turn something on or off, it says “turning two lights on/off.”

@Lars - should the reconnect option remove my dupes?

Absolutely worked for me! Thanks