[Resolved] Google Home connect to SmartThings error

I just got my pre-order Google Home last night. I got it set up and tried to add my SmartThings account. Whenever I attempt to connect, I select my location and check all the boxes to control my lights. When I click Authorize, I get redirected to a 500 error from smartthingsv2-dot-iot-adapter.appspot.com. I have tried several times again this morning with the same results. Is anyone else having issues? I have tried searching on here and the Internet in general and have not found anything. I do have an original Kickstarter hub, but I have not seen anything that indicates it shouldn’t work. Unfortunately, there is not any information about what went wrong.

I have tried adding just one light (instead of all of them), but that gives the same result. I have tried looking at the live log (graph.api.smartthings.com/ide/logs) and I see messages there from “The Google Assistant” but nothing that indicates an error. Does anyone have any ideas for troubleshooting or know how to fix it?

I don’t have a GH as yet. I’m still watching and learning from the experiences of early adopters before I decide on Echo or GH.

Do you have a V1 hub? You said it was an original Kickstarter hub so I wondered about the version. The error message you posted says V2 IOT…

Receiving the same error, the backend seems to be busted at the moment.

Yes, it is a V1 hub (meant to imply that by saying original Kickstarter, I should have been clearer). I noticed there was a v2 in the URL string and am hoping it isn’t related to the v2 hub.

So far I am liking the Home (just wish I could get ST setup as that would be awesome). I am heavily invested in Google services, so it made more sense for me than an Echo. I was tempted to get a Dot because they are so cheap but held out for the Home.

I am hoping that is all it is. But I have seen some people have gotten it setup and the Home has only been out for a couple of days now. Out of curiosity, do you have a V1 or V2 hub?

I haven’t seen any discussion about V1 vs V2 with GH. Hopefully this is just a temp problem and both you guys can get the association going shortly.

This seems to be an intermittent issue on Google’s end. Please use the “Help & feedback” section of the Home app to report this issue. Mention “SmartThings” specifically and we’ll work with Google to fix it.

Try again in a few hours and I’d expect it to work.


Thanks, I just tried it again and it worked fine!


Still not working on my V2 hub. Sometimes I’ll get the 500 error after selecting devices and other times after logging in I’ll get a splash page instead of devices.I figure it’ll clear up soon.