Google Home changed link so now ALL devices get added, you can't pick anymore


(Ron) #1

My Google Home stopped working. It said I needed to update the software to link with SmartThings. The app said I needed to relink the account.

But when I relink it doesn’t present the list of devices anymore.

This is really annoying because I have 50+ devices including all kinds of virtual buttons as hacks to make other integrations work like flic buttons, amazon alexa, etc. So names are very similar and I only want to control about 5 devices, not 50.

Is there a way to get back to the old link which lets me select which devices I want linked?


#2

I can still pick just fine. Go into the Google SmartApp. There you can select which devices to expose to Google.


(Ron) #3

Thanks, I looked for the Smart App the wrong way. I looked at the smart apps section for a device in the google home list and it wasn’t there so I thought there was no longer an app. Now that I checked under automations-smartapps it is there and somehow it was defaulted to allow all devices. I switched it to let me select and it is back to normal now. Thanks!


(Joel) #4

I had an unknown error all the time. So tried to relink but now it’s asking for Samsung smartthings account and my St password is not working.


(Ron) #5

I had this issue also. Check again there are two login options listed in Google Home. one is for “Samsung Smart Home” which I think you are trying to use. The correct one is listed as “SmartThings/Samsung Connect”


(Joel) #6

i’m blind thanks got it!


(Joel) #7

Frustrating. Still getting unknown for device name

Is g home control over smartthings working for others ?

Note it’s also not working for lifx integration. I excluded these from having access in g home via St setup and added lifx as it’s own integration.


#8

G Home integration is working fine here.