Cannot add new Smartthings devices to Google home


#1

I have been using Google home with smartthings for months with mostly no issues. Since last week I have been unable to add any new devices though.

Previous I would just select smartthings in the home app and the it would let me log in and reselect which devices to add without deleting what I already had. Now the only option I get is to unlink/remove smarthings.

Anyone else having the same problem? Any tips?

Thank you!


(Ahmed ElSerafy) #2

Yes!!!, same issue here now, i’m with google home support now about it…

did you find a fix?


(Ahmed ElSerafy) #3

they said they will escalate my case, not sure if its only me or others as well and they will get back to me…


(jkp) #4

There is another post that reflects some Google Home issues…


(Adrian Marano) #5

Could you fix the problem ?? i am in the same


#6

Doesn’t look like it’s limited to SmartThings. I added Wink and now all I can do is unlink it. WTF?


(J.R.) #7

Same boat. I had to “unlink” and then “relink” just to add a new devices…then I found out after I “relinked” it now automatically picks up any new devices I add.


#8

I’m having this same issue. Is the only option to unlink and relink? It’s going to suck re-creating all my automations if this is the case.

I noticed that the SmartApp installed on my phone is Google Assistant; but both SmartThings and Google refer to the Google SmartApp. So I think someone may have changed the app?


(J.R.) #9

You will have to “relink” once. After that it will automatically pick up new devices as you add them.


(Bob) #10

This has been posted in the above mentioned thread.


This issue was introduced when we launched the new Google Assistant integration a few weeks back and only affected users who unlinked the old integration and linked to the new integration, or installed Google Assistant for the very first time.

However, it took a while for us to figure out the cause since it related to only custom device type handlers. We do thorough QA on our WWST devices but there is no way for us to test all custom smartapps and device handlers. Since it relates to custom code, it only affects a smaller number of power users and not the majority. As a reference, we got about 10 support tickets on this which makes it hard to track down.

As mentioned before, the official fix will deploy today or tomorrow (it has passed our internal QA)
Lars
Engineer at SmartThings


#11

I’m honestly not sure that thread describes the same issue, though they do seem related. I checked and I still have Google Assistant in my smart apps and the only option in Google Assistant settings is still to unlink.


(Cmin Tang) #12

Hi… i have successful added account to GH… but i cannot find anything there and i have no problem with Hue…

anyone can help?


(ozzy) #13

In the Google Smart app in ST, have you enabled “Device Authorisation” and saved?


(Cmin Tang) #14

thanks … issue solved…
I was adding Samsung Smart Home (this logo)
image|34.2x27.4

Instead of “Blue logo”
image|55.3x16.3


#16

I had this problem.
Tearing my hair out for days
Then I changed my default browser on my phone from Samsung Internet to Chrome
Problem solved.


(kelvin) #17

Now need to say “sync my devices”