Cannot connect Google Assistant to Smartthings


(Brian Kopp) #1

Running google assistant on an S8 with Android 7.0 and I have a Smartthings hub that is online.
When I follow the instructions to connect Google Assistant to the hub and select the Google Assistant Device “SmartThings / Samsung Connect”, I get as far as the authorize button and the response after I press it is the message “Couldn’t update settings. Check your connection”

Anybody seen this and solved it?
Thanks,
Brian


(Adrian Gates) #2

On your phone, long press the Home button to open the Google Assistant.
Tap the blue icon in the top right.
Tap the three vertical dots.
Tap Settings.
Tap Home control.
Tap the three vertical dots.
Tap Manage accounts.
Tap SmartThings / Samsung Connect.

Let us know if this helps you

Adrian Gates
Sr. Developer - Apps4Rent


(Brian Kopp) #3

Yes that helped. Looks like they are linked.
Thanks!
Brian


(Adrian Gates) #4

Happy with it :slight_smile:


(Isaiah Rojas) #5

Been getting this same error and and can’t seem to get it connected. Was connected before and now it doesn’t.


(Henry Leung) #6

I already have a few ST devices linked to Google Assistant successfully. Today I tried to add a new device and I ran into problem: Failed to link accounts / “Couldn’t update settings. Check. your connection”. This happened before and I restarted my tablet and it worked. But this time restarting the tablet doesn’t help. I followed your steps but to no avail. Any idea why? Thanks in advance.


(John Franklin) #7

I’m trying to link my ST hub to Google Assistant. It works in the ST app, but when I follow all the right steps in the GH app, I get the response that the accounts are successfully linked but the ST hub doesn’t show up in my device list and Google Home doesn’t find the device. I spent an hour on chat with Google last night and they’ve followed up via email with 2 more questions today, but still no resolution.

Anyone have an idea on this one? Thanks!


(Derek Morais) #8

Tap the + icon in GH. Then tap set up device. Then “have something already set up”.

SmartThings should be showing there with the SmartThings devices if you set it up correctly.

If it’s not I would recommend logging into IDE and making sure GH is disconnected there as well as in the ST app. Then reboot everything and try adding ST through GH


(John Franklin) #9

Thanks, Derek! I tried all your suggested steps, and still no luck. Spent >1 hour on phone with Smartthings Support, now waiting for a call back from Google Home support again. I’ll let you know what we figure out. Grrr.


#10

John, please let me know if you figure this out. I’m having the same issue. I allow access to my hub, it succeeds,then takes me back to the Home app where it doesn’t appear.


#11

Actually nevermind I figured it out. I went into the IDE, selected my location, and then went into smartapps. I removed the Google smart app. I also have a hub for my condo building and I made sure it wasn’t in that location either.

Then when adding it in the home app it worked!


(Craig Biondi) #12

Answer42, I’m having the same problem and am thrilled you’ve figured it out! What is “IDE”? Thanks for helping a neophyte.