Can't get Google Assistant to control SmartThings

So I used to have this working. It “just worked” before without any unintuitive, complicated setup. But since resetting my phone and setting it up fresh, suddenly I can’t get this to work for some reason.

I’m on Android 9 “Pie”. Installed Google Assistant, that’s all working fine (responds to “Ok google…” commands in and of itself). Under Settings I’ve linked it to SmartThings by logging into my Samsung account. All my sensors appear, I can assign them to rooms, etc. And from the separate Google Home app, from there I can successfully control things fine (such as turning a lamp on/off and adjusting its brightness). So that’s all set up correctly. Google Home is properly linked to SmartThings independent of Google Assistant, and can see and control ST just fine via on-screen controls.

The problem is, Google Assistant seems to not understand voice commands to control the “SmartThings” home stuff. I used to be able to say “(ok google) turn on the living room light” or “make the living room light green” or “what temperature is the living room” and it’d respond correctly. Now when I say those things, it just does a google search on the phrase. Something’s broken and I can’t figure out what, partially because I’m setting this up clean so nothing is weird, and also partially because I clearly remember when I tried this before, it just worked with the simplest of obvious setup. I have no idea what I could be missing this time around. Help?

Hi, yeah I get this sometimes randomly with my google assistant, also I found this happening as I was messing around with the google privacy settings and as you said you have refreshed it probably needs you to click a few boxes to allow access again. Hope that helps

Thanks, but I don’t really have any “boxes” left to click. The setup isn’t convoluted enough to mess up. Something else is broken here.

Hi have you checked your google activity controls ?

Well, I hadn’t gone in there for anything, but I just checked and everything is enabled. None see to really apply to this however.

That happened to me a couple times. I ended up removing ST and relink my account on Google Home to get it working again.

It’s happened to me also and I’m trying to recall what I did, have you asked google to synchronise with smartthings?

I’m having the same issue as the OP. I just moved and recreated my home devices and now all 20 smartthings devices do not work with voice. Any help for how to fox this would be much appreciated

Hi. I am running into this same problem since I updated to a new Galaxy S10 Plus. I tried all the suggestions above and cannot get it to work again. I use basically the same commands as the original poster did. It used to work flawlessly now nothing works. Please help! I already tried unlinking/relinking to ST.