Google Assistant Home Control


#1

Just got google assistant update on my Moto Z, but home control isn’t showing up. Anyone else able to use home control with recent update on non pixel devices?


#2

Until yesterday i was using a modded build.prop to enable assistant, and i had home control
Since Google announced the rollout, I’ve lost the home control setting although I was still able to control the lights using it.
So I started wondering if they started hunting modded versions, so I’ve rolled back to Google now until the assistant comes. Now that you are mentioning, I’m started to wondering if they removed it, or if it’s a server side switch


#3

From what I’m reading, the Google Assistant might be in version 6.13 of the Google app. I received that version yesterday, but I still do not see the “home control” option available in the Google Home app. I sure hope they deliver this feature the way I’m (and you guys too) are understanding it where we can use “OK Google” to control Smartthings without the “Google Home” hardware device. Since you said it was working for you on a modded build.prop, then we know it can happen. Come on Google!!!


#4

Yep, was working flawlessly. I was able to toggle my lights or query the state of it, was able to assign room or name if I remember correctly and I don’t have Google home hardware. But as I said yesterday after the announce the setting just disappeared, although I was still able to Interact with it

Right now I have version 6.14 ,and still don’t have assistant here :confused: so they must have some kind of server side switch


#5

Just saw this @Reddit
"If you can’t access Google Assistant’s Home Control settings, go to ‘What can you do’ (top right dots in the settings) and scroll to the bottom of the list."
Might be worth a shot


#6

So i went digging further…and not using google assistant before, I thought by just having the right version of google apps and play services means i’ll get google assistant…now i realise…i’m still on std google now…
from what i gather…it’ll take a few weeks for google to activate google assistant on each devices…
I’ll update once this becomes available and if home control shows up.
sorry…


(Justn ) #7

Nexus 6p on 7.1.2 and still no assistant yet. Seems totally random as to who’s getting it. Play services updates don’t seem to be doing it. I have see a few US users get it today, so hopefully soon!


#8

I sure hope this happens since we can’t rely on Samsung to bring Smartthings support to their SVoice service. I’d really like to have Samsung’s SVoice integration with Smartthings since I mostly have Samsung devices. Especially the Gear S3 where I could just tell my Samsung smartwatch to do Smartthings stuff. It’s just typical of Samsung to half-bake their services and not inter inegrate them across the board. If Google actually turns this on, then that’s a big slap in the face to Samsung’s SVoice group.


#9

Just received the assistant update

Happy camper here, I have home control, I’m able to control the plug as before and query the state.
I really can’t tell what else can you do, I’m new to home automation so I only have a plug and some sensors


(Bobby) #10

FYI…Galaxy S7 Edge. Assistant Working great without a Google Home!


(Jason Fournier) #11

I setup smartthings (authorized devices) and added everything to rooms, however when I say a command like “turn on kitchen lights” it still just does a web search for turning on kitchen lights. Am I missing something to turn on the feature?


(Brad) #12

I’m getting the same response.
Edit:
After playing around with Google, it seems as though I did have to “activate” Assistant. I set up all the home controls originally by swiping left from the home screen or holding the home button to go into the Google screen and going to settings. But when I would say “OK Google, turn on the living room lights,” it would do a web search. So I found some info about launching assistant by holding the home button and then swiping up. So I did that, and then it popped up a message saying “Congratulations, you have Assistant”. Now it works by the previous “OK Google” method. It’s worth a try.


(Michael Harman) #13

One thing I’ve found is Assistant doesn’t consider connected switches (I have a GE dimmer switch) to be lights. I have two hue blooms and the GE dimmer switch in the same room. If I say ‘Hey Google, turn on the family room lights’ it will turn on the hue lights, but not the dimmer. However, in another room I have a Zooz Zwave outlet and it considers that a light.

My wife has a tendency to just say ‘Hey Google, turn on the lights’ and then I have to go back and turn off the office lamp and the hue bulb we have outside the back door.


(Brad) #14

I was having an issue with this also, but my work around is to set an alias thats the same as the room. For instance, in my kitchen I have Hue strips under the counters and a GE switch to control overhead recessed lights that I had named “Kitchen Cans”. So when I told it to turn on the kitchen lights, it would only control the strips because it didn’t see the switch as lights. So I set an alias for the over head lights to “Kitchen Lights”. Now when I say “Turn on the kitchen lights”, they all come on (or off).


(Charly Arg) #15

Just registered to say thanks! I knew I saw it but couldn’t find where. Google should be more consistent.


(Jason Fournier) #16

It is working now. It seems I didn’t fully have Google Assistant. I had the app but some background stuff must not have updated yet. I tried it again today and everything works.


(Ammar) #17

Worked! thanks. It’s a little weird though, the only light switch I have is in my porch, everything else are dimmers, and you can’t say turn off dimmers you’ve to say for example “dim the living room” but that only dims it by like 10 or 20%, the only way I could shut it down is to say “set living room dimmers to zero” then the lights went off!! weird.