Getting hue bulbs back after V2 Migration

Has anyone who has upgraded to the v2 hub had an issue adding your hue to the new hub? I cannot add it to my v2 hub? I have tried half a dozen times, waiting 10, 15, 30 minutes but nothing. It finds the bridge but nothing after that. I have a ticket open with ST but have not heard anything from them. Actually, I believe I have three open tickets with them and have horrible experiences on each ticket. Does anyone have any ideas? Anyone get this fixed on their migration to v2?

Sorry, had no problems readding the bridge to my V2…Did you remove it from v1 (just throwing ideas out there)?

Did you completely remove your previously location? If so, did you remove the hue bridge device before?

If the hue bridge device is stuck in old location or the old hub v1 is still on the network, the hue can get stuck thinking there already is a hub paired.

Yes, I removed everything without having to get support involved and the v1 hub/location is completely removed and powered off. @SBDOBRESCU, it finds the bridge then the next screen say push button on bridge to link which I did. What should I do/see next and on what screen?

My Hue hub took a few attempts to be found, then a few minutes for the Hue bulbs to show up.

Calling out @juano2310 for help with your case! May be he can provide some insight. @hscox030!

I see the following in the logs:

6:22:02 PM CDT: debug getChildDevices(false), children=0

6:22:02 PM CDT: debug Device (C256278C3234) was already found in state with ip =

Hi @hscox030,
Do you mind copying the log from hue (connect) during the process of linking? I would like to see what is failing there. Also, are the hue bridge and the st hub connected to the same router?

@juano2310, I sent you a PM with the log info you requested. Yes, but I have the hue connected to a wireless extender via a physical RJ45 port on the extender. It discovers my hue bridge within seconds, just nothing after that.

Awesome, what I will do is modify the code a little to have better debugging tools. I will send you the files if that’s ok with you.

I am having the exact same issue with the Hue Hub link. I did remove everything from the previous hub manually. The Hue hub is detected right away, but the app never recognizes the Hub link button being pushed. I did link the Hue Hub with a few other things to make sure it wasn’t that (website, Alexa, etc) and it connects properly.
(The nulls continue while I hit the link button)

6e5c5d41-56a8-4e61-b812-15e9b2ffc21e ‎9‎:‎27‎:‎39‎ ‎AM: trace Bridge: 00212F34F899 - Host: null

6e5c5d41-56a8-4e61-b812-15e9b2ffc21e ‎9‎:‎27‎:‎31‎ ‎AM: trace Bridge: 00212F34F899 - Host: null

6e5c5d41-56a8-4e61-b812-15e9b2ffc21e ‎9‎:‎27‎:‎28‎ ‎AM: trace HUE BRIDGE RESPONSES

Button Pushed Here
6e5c5d41-56a8-4e61-b812-15e9b2ffc21e ‎9‎:‎27‎:‎28‎ ‎AM: trace Location: index:03, mac:000420E8D344, ip:C0A8018A, port:201E, requestId:f9f5d941-a41d-48a2-a722-aad8f264bb7e, headers:SFRUUC8xLjEgMjAwIE9LDQpDYWNoZS1Db250cm9sOiBuby1jYWNoZQ0KUHJhZ21hOiBuby1jYWNoZQ0KQWNjZXNzLUNvbnRyb2wtQWxsb3ctT3JpZ2luOiAqDQpDb250ZW50LUxlbmd0aDogMg==, body:W10=

6e5c5d41-56a8-4e61-b812-15e9b2ffc21e ‎9‎:‎27‎:‎24‎ ‎AM: trace Bridge: 00212F34F899 - Host: null

6e5c5d41-56a8-4e61-b812-15e9b2ffc21e ‎9‎:‎27‎:‎17‎ ‎AM: trace Bridge: 00212F34F899 - Host: null

6e5c5d41-56a8-4e61-b812-15e9b2ffc21e ‎9‎:‎27‎:‎10‎ ‎AM: debug getChildDevices(false), children=0

6e5c5d41-56a8-4e61-b812-15e9b2ffc21e ‎9‎:‎27‎:‎10‎ ‎AM: debug Device (00212F34F899) was already found in state with ip =

I am going to try and assign the hub to a different IP and see if that makes a difference. (edit) it didn’t.

Absolutely, send me whatever you would like and tell me what to do with it. I will do whatever I need to get my hue connected again.

Lets try to track the problem,

Please install this as a smartapp:

and this 3 as device types:

After installing all this please go to “My Apps” and install Hue from there. Keep the live log open and send me the log of the whole process.


Hope this works for people having issues. But we really do appreciate your efforts @juano2310

Will it see both the virtual bridge and my actual bridge? I assume I select the virtual bridge. I’ll give it a try after I get home in about an hour.

Power cycle your phone.

A bit off topic but in case anyone doesn’t have a hue bridge, like me and you added your bulbs directly to ST Hub there is no easy way to add them to the new hub. The bulbs need reset and the only way I know of is with a RaspBee which I ordered and will be here tomorrow.

I am having the same problem. I did not upgrade to the V2 ST hub. Instead, I created a new account with a different email address and started to config ST from scratch. It won’t find my Hue hub and gives the same message in my ST log during discovery: "was already found in state with ip = ". I’ve power cycled my router, hubs, switches, etc and still have the same behavior. Email in to support with no response :frowning:

I did the same thing in creating a new account. It was too difficult dismantling the old one and I have way too many devices. I also had the same issue with the hue bridge and thought it might have something with the IP address, but it looked okay. Somehow during that process/trouble shooting it started to work (an hour perhaps) and I’m not sure why. After getting the bridge and hue bulbs discovered, I could not save the device and kept getting a failed to save error. I’ve got 42 hue bulbs. I finally got that to work by saving 4 bulbs at a time. It took awhile but worked.

Support tells me that development released some new code to address Hue problems and that should have resolved my issue, but I’m still having no luck. During discovery I still get the “was already found in state with ip =” message in the logs.

I’ve changed the Hue hub IP address, made it static, rebooted ST and Hue hubs repeatedly, connected both hubs to same physical router. ST was connected via Ethernet switch previously. Still no change in behavior and no luck. Considering reverting back to ST V1!!

PLEASE SmartThings, make Hue integration work well…!