Smartthings not finding new Hue bulbs

I’ve added 2 new Hue bulbs to my Hue bridge so that part works just fine. However they are not showing up in ST and it also cant find them.
I already have the Hue Bridge set up on ST for over a week (which took the better part of 4hrs and about 7 tries in the first place) and it shows every bulb, until now. Even Alexa knows about the new ones now, via Hue.
I’ve read every thread I could find. I’ve tried to add them to ST, ie “add a thing”. I’ve rebooted/power cycled both the Hue Bridge and the ST Hub several times. I’ve turned the lights off/on to force ST to ‘find’ them. Nothing works.
I’m not going to even try to delete and reaquire the Hue Bridge because to me that would be absolutely stupid if I had to do that every time I added a bulb.

Setting up all this shouldn’t be this hard. I’m starting to regret not only returning the Wink2 but also starting this whole HA process. I just may go back to my ‘dumb’ bulbs. At least they worked without giving me a massive headache every day.

well, can see this is going nowhere…

What happens if you press the button on the Hue Bridge and then select add a New Thing and see if it discovers the additional Hue bulbs.

Have you contacted support?

How many bulbs are paired to your hue bridge and how many do you see in SmartThings?

hmm…does the order matter? Hue botton first, then ‘add a thing’, or vice versa?
I’ll try it both ways.

Are both (Hue Bridge and ST Hub) connected to the same network switch?

1 Like

Was my next question, but waiting for him to finish his reply. He’s typing. I’m assuming he has it plugged in to the same because he had it discovered for 4 days with bulbs on it already. Unless he moved it after initial discovery of everything.

@jkp, yes. they have been running for a while on my home network
@Brad_ST, @WB70 Had 16 Hue Lights, 14 showed on ST.
Right when I went to try the Hue button/add a thing trick, I saw that most devices said “unavailable”.
I’ve gotten that before and remember shutting off Device Health for it. Rechecked and Device Health was turned back on. wth…
Turned it off (again), waited, nothing. Closed and restarted the app, waited some more. and now I have 16 lights on both.

Now that is something I didnt come across in the forum. Guess knowing Device Health isnt really worth it.

Problem solved then?

@WB70, yes.
Although I found it strange that if the devices showed as ‘unavailable’, possibly because of the change from the Hue bridge, that it took so long to see that on the app.
Hue must have had a tantrum.

They have made improvements to device health over the last couple of updates, but there are still some idiosyncracies. I personally leave it off.

Remember, when there is a firmware update or a mobile app update, check the device health to see if it automatically got turned back on.

ST staff said they don’t believe that this could get turned on by a firmware update, so most likely it’s happening on a new mobile app update. Just something to remember.

A lot of 3rd party apps require that you press the button on the Bridge to acquire the bulbs from it. That most likely caused them to show unavailable from ST because it puts the Bridge into a type of pairing mode.

:rofl: Coincidentally I just received this email 30 seconds ago. So this also could have played into the unavailable devices.

Investigating

Some users may be unable to load the SmartThings app, control devices, or access the web UI. We are currently investigating.
Jan 16, 18:46 EST

I can confirm. The Mobile app will not load right now. It was fine 5 minutes ago. Walk away for a while before you continue to play.

@Brad_ST FYI

Looks like I beat you by 5 minutes in updating status.smartthings.com :slight_smile:

1 Like

Update: Not only did it have trouble discovering the 2 new Hue lights for a while (fixed) but today it wouldnt discover a GE Z-Wave Plus Fan Switch. At least the android app came up blank for about 5 minutes, even after pressing the paddle. So closed it. Grabbed my iPhone, opened ST app there. The iOS app discovered it in about 15 seconds. Didnt even have to press the paddle on it.

You would think that the app platform shouldnt matter, but it apparently did.

I go to Settings>Connected Services>Philips Hue and then go back to main screen. This solves it for me immediately.

i’m having the same issue you did. added 2 new bulbs, never showed up in ST via my hub. separately, i connected to Hue using the cloud service without the ST hub and all of my bulbs imported, but that means i now have many duplicates plus the 2 new ones, and they’re cloud connected and not local, which is not ideal.

doesnt seem to be a way to turn off device health watch in the new app. not totally sure what to do next

edit: got it. i went to add device, chose Philips Hue and the “with smartthings hub” option. i then imported the missing lights and only those.