Gentle wake-up in new app?

Gentle wake-up SmartApp activated in Classic App, then settings adjusted in new App. Working fine as timed function. But in new App, I can’t access the (virtual) device it creates. Says something like “Can’t make a connection, check the device and try again”. All fine in Classic App, but how can I start/stop it manually in new App?

2 Likes

The DH of the child device should be updated to work in the new app. Try to reach out to the developer of the SmartApp.

It’s “by SmartThings” so I thought It already could/should be compatible with the new app. Apparently not.

1 Like

Send an email to support. As that is one of the “official” apps, and should work then in the new app. It must need to have a few lines of code added, and would work flawlessly. But looking at the last updates, it hasn’t really been updated for the STSC app.

The Timed Session capability is something what I haven’t seen anywhere before. But the old documentation lists it, but not the new. They probably hasn’t released any standard UX tile for it yet.

1 Like

Done. Thanks Gabor for your input.

Any luck? I’m having the same issue.

Nah… got only reply saying that my feedback is passed to ‘relevant team’ . This was back in March. No change in Smart App. They say that time slows down near the black hole. I think Smartthings is one.

2 Likes

You can have a look on the new Custom Capability documentation. That has an example for the Gentle Wake Up. You might want to implement it by yourself.

Thanks but I’m not planning to be SmartThings developer. If the wake-up light will be updated by someone some day, I’m happy. If not, I can live with that too. No need for wake-up light atm up here in north, sun shines almost all-night anyway :sunglasses: .

Is Gentle Wake-Up gone? I was using this every day as part of my wake up routine and now all I seem to be able to get is instant on rather than a gradual increase in brightness that I had with the Gentle Wake-Up controller. Not pleasant.

Please see my previous post above. It hasn’t been updated. You can do it for yourself using the guide (you might need to look at previous version of the linked post, as it has been updated since then…)

Hi, it is October already and I am forced to use the new version of ST. I have just “migrated” to the new one. I am very fond of my “Gentle Wake Up”; it appears in the list, but it is not recognized. I have just now gone in the IDE to try and see if I could do it through it, but is still in the same state. Like someone else mentioned here, I do not have the desire or the capability to become a coder or a developer. I barely can copy and paste code to create a smartapp in the IDE. Is there any way anyone here can tell someone who is truly a beginner how to implement this with the new friggin app, please?

I am attaching a screenshot of the response I get when I try to activate Gentle Wake Up.

PS: when I tried to do it through the IDE, I got this error:
physicalgraph.app.exception.UnknownDeviceTypeException: Device type ‘Gentle Wake Up Controller’ in namespace ‘smartthings’ not found. @line 305 (initialize)

2 Likes

As a work-around, if you happen to use Google Home/Assistant, you may try https://support.google.com/googlenest/answer/9304145?hl=en
I haven’t tried it myself yet.

1 Like

Gentle Wake Up no longer creates a hook to use in Smart Lighting smartapp or automations or scenes.
Way to go Samsung. You forced me to use new app which broke my home automation. Such “upgrade”!

Have a look at this:

In Europe, Spain, with android & iOS and América & Asia if You does not have android, this version modified and Publishing dth gente wake Up controller for you works in new app.

The DTH Gentle Wake up Controller does not need to change any code. You only have create dth and publish it for you in IDE.
And the smartapp only need remove the line 253 // input (name: “completionPhrase”, type …
in completion Page.
I found 2 bug too in SmartApp:

  • does not reach the final % if the total time is too long
  • App can restart dimming if smartlighting app send several times the On command to controller.
    Resolved in SmartApp in my previus link.